specific file download causes system hang (need to reset the PC)

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Jean-François KAPPES, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

failed several times to download the file below:
http://prdownloads.sourceforge.net/filezilla/FileZilla_2_1_3a_setup.exe?download
which causes system hang. Mozilla does not respond; can't be killed; PC can't be
restarted unless reseted.

Reproducible: Always

Steps to Reproduce:
1.try downloading filezilla setup.exe file.
2.
3.

Actual Results:  
mozilla & co hangs.

Expected Results:  
download expected file

Comment 1

15 years ago
WFM 
Build ID: 2002121215 (1.3a)

Comment 2

15 years ago
WFM - 2 hours old CVS based build - WinXP-Sp1.

Any 3rd Party theme ? Did you try deleting xul.mfl file in your profile ?
Probably a dupe of 161783.

I've seen precisely this behavior. I'm on Windows 2000 and have a very long
Download History. Searching and updating of history is O(N) (linear - many items
=  very long system hang).

http://bugzilla.mozilla.org/show_bug.cgi?id=161783

Comment 4

15 years ago
wfm.  Reporter, can you still reproduce this bug?  If so, please answer the
questions in comment 2 and whether you agree with comment 3 that it's a
duplicate of bug 161783, i.e. caused by a very long download history.   That
could be tested by clearing your history and trying to reproduce.

If you can no longer reproduce the bug, please close it as wfm.
(Reporter)

Comment 5

15 years ago
Can't reproduce it now. Close as WFM as requested. thank's for following-up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.