Closed Bug 1855694 Opened 10 months ago Closed 10 months ago

Only send the remote type prefix

Categories

(Fenix :: Experimentation and Telemetry, task)

All
Android
task

Tracking

(firefox118 unaffected, firefox119 fixed, firefox120 fixed)

RESOLVED FIXED
120 Branch
Tracking Status
firefox118 --- unaffected
firefox119 --- fixed
firefox120 --- fixed

People

(Reporter: willdurand, Assigned: willdurand)

References

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

To make sure we're sending the same remote type values as the (legacy?) crash annotations, we should also trim the values in the ChildCrashHandler like it's done here: https://searchfox.org/mozilla-central/rev/6b91b922725838e2732aeb478b13e5b33e33ce1b/dom/ipc/ContentParent.cpp#726-735

Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51fa8a3c99f0
Only send the remote type prefix. r=gsvelto,geckoview-reviewers,amejiamarmol
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch

Comment on attachment 9355566 [details]
Bug 1855694 - Only send the remote type prefix. r?gsvelto!

Beta/Release Uplift Approval Request

  • User impact if declined: None. This is a fix to a Glean probe.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is low risk because the patch has automated tests and it only affects crash pings. The change is to trim a value to only report remote type prefixes instead of full values.
  • String changes made/needed:
  • Is Android affected?: Yes
Attachment #9355566 - Flags: approval-mozilla-beta?

Comment on attachment 9355566 [details]
Bug 1855694 - Only send the remote type prefix. r?gsvelto!

Approved for 119.0b5

Attachment #9355566 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: