Closed Bug 1855871 Opened 5 months ago Closed 1 month ago

Delay when using search bar before loading occurs, likely caused by Kaspersky

Categories

(Core :: Performance, defect)

Firefox 118
x86_64
Windows 10
defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: hivih25096, Unassigned, NeedInfo)

References

Details

+++ This bug was initially created as a clone of Bug #1093571 +++

Steps to reproduce:

  1. Open a new tab
  2. Type a search term into the search box on the page
  3. Press enter or click "search"

Actual results:
So I've been having this issue where when I press enter after typing in a search, the browser takes about 5 seconds before even beginning to load. After the delay, the search is performed as normal. It acts like it's frozen and then after 5 seconds, it begins the loading process. It doesn't happen every time but it does happen more than it should.

Expected results:
The search should be performed immediately. Even if the actual loading time takes longer, the time between pressing 'return' and loading shouldn't be long.

What I've tried:
I tried disabling my anti-virus safe searching mode (Kaspersky) but it still happens. I also tried to uninstall and reinstall Firefox, as well as clearing all cache and data, but no luck. I've also tried creating a new profile and running it in troubleshooting mode.

Would it be possible for you to post a video of the behaviour? Alternately, getting a profile might help us analyse the issues: https://profiler.firefox.com/

Moving to untriaged for now as it is uncertain what area is actually causing the issue.

Points: 5 → ---
Component: Search → Untriaged
Flags: needinfo?(hivih25096)

There have been other reports of this kind of problems related to Kaspersky, here on Bugzilla in bug 1830217, and also on Reddit here and there. Some recommendation from another user on Reddit: Can you try in Kaspersky to disable Security>Network settings>Inject script into web traffic to interact with web pages and see if that works better? A performance profile would be very helpful as well, as asked by [:standard8]. Thank you.

Summary: Delay when using search bar before loading occurs → Delay when using search bar before loading occurs, likely caused by Kaspersky
See Also: → 1830217

This issue seems duplicate of bug 1830217, setting component so that engineering to confirm. Thank you.

Component: Untriaged → Performance
Product: Firefox → Core
Hardware: Desktop → x86_64

This bug was moved into the Performance component.

:hivih25096, could you make sure the following information is on this bug?

  • For slowness or high CPU usage, capture a profile with http://profiler.firefox.com/, upload it and share the link here.
  • For memory usage issues, capture a memory dump from about:memory and attach it to this bug.
  • Troubleshooting information: Go to about:support, click "Copy raw data to clipboard", paste it into a file, save it, and attach the file here.

If the requested information is already in the bug, please confirm it is recent.

Thank you.

Flags: needinfo?(hivih25096)
QA Whiteboard: QA-not-reproducible
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.