Open Bug 185612 Opened 19 years ago Updated 16 years ago

[xbl form controls] can't focus to nor type into any text input field

Categories

(Core :: Layout: Form Controls, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

People

(Reporter: bugzilla, Unassigned)

Details

(Keywords: relnote)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Trying to put the focus on any text field by clicking or using the tab key
fails. After clicking there is just no caret and nothing can be typed into the
field. If I try to use the tab key to bring focus to the text field it is just
left out, e.g. the master password box for the software security device has one
text field for the pw and two buttons (OK, Cancel). Pressing tab just toggles
between OK and Cancel, the text field never gets the focus.

Reproducible: Always

Steps to Reproduce:
1. Click into any text field (Location bar or File->Open Web Location)
2. Try to get a caret by clicking into the text field or try to switch to the
text field by using the tab key.
Actual Results:  
The field does not get focus, no caret appears, nothing can be typed in.

Expected Results:  
Focus is put on the text field, caret appears, text can be typed in as normal.

I use the classic theme, this happens with modern as well. Everything works fine
on the same machine using 1.2.1. This behaviour could be observed with all
latest nightly builds during the last two weeks.

It is possible to force focus though by *right*-clicking into the field (i.e.
invoking the context menu) and then using arrow keys. It is also possible to
gain focus using a key shortcut if available (i.e. CTRL-L for location bar or
ALT-S for Subject and Sender-Search in messenger).

If there was a hotkey for every textfield I would give this a minor, but e.g.
entering the master password is quite difficult the way it is now.

I know this sounds like #82534 but I've never experienced this since I started
with M13, to me this is new with 1.3
I copied the mozilla folder to another Windows XP machine ans there it works.
Does anyone have any suggestions what to look after on the Windows system, that
probably interferes? Remeber 1.2.1 and previous versions worked as excpected.
WFM. 2002121608 / XP.  (And has never not worked for me.)

Try a completely clean install of Mozilla and/or creating a new profile.
> Remeber 1.2.1 and previous versions worked as excpected.

Do they _still_ work as expected. i.e., what happens if you run them now? 
[Just trying to distinguish between internal and external causes].
John, Jason,

thank you for your hints. Trying with an empty profile finally led me to the
error. I had XBL-based form controls enabled
(user_pref("nglayout.debug.enable_xbl_forms", true);) which caused the problem.
On the same machine using them in any build prior to 1.3 worked fine but with
1.3 it did not. Disabling XBL-based form controls restored normal behaviour.
Severity: major → enhancement
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
I just experienced this bug using 1.3final on WinNT4, and spent a couple hours
tracking the problem down.  Removing the "use_xbl_forms" pref restored function.

Reopening this bug, recommending either a release note or an automated removal
of that pref (or both).
Status: RESOLVED → UNCONFIRMED
Keywords: relnote
Resolution: WORKSFORME → ---
Correcting previous entry.  It was the "nglayout.debug.enable_xbl_forms" pref.
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> bryner, if he wants to disable this, at least in the interim, since it is 
no longer functional, at least on windows, to set this pref.

I'll email asa to release note this.
Assignee: jaggernaut → bryner
mozilla/5.0 (x11; u; linux i686; en-us; rv:1.3) gecko/20030403

This problem also happens on my install of Mozilla.  It appears to be random
though and very difficult to track down the actual cause.  Text input fields
will work normally for a time and then decide no longer to focus on click.  I
can not TAB into the fields either and have found no workaround.

nglayout.debug.use_xbl_forms is set to false.

select boxes, textfields, checkboxes, radio boxes and other form elements work
as expected.  

I have not tried the CTRL-L solution yet to get focus back into the Location
Bar, but will once this problem occurs again for me.

This build of mozilla was created using Gentoo linux (1.4_rc3) and built from
source.  This problem occured for me on my Slackware 8.0 install as well using
mozilla-installer.

Gentoo make.conf settings:

USE="-kde -gnome -arts -3dnow cdr dga gtk2 mozilla innodb mysql -oss sse tcltk
usb cups xml ssl"

CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"




Roger: what you're hitting is not this bug, because this bug is 100% repro and
only happens with xbl form controls enabled.  The bug you're hitting sounds more
like bug 214206.
Summary: can't focus to nor type into any text input field → [xbl form controls] can't focus to nor type into any text input field
i have same problem : can't put focus on control text, and other control aren't
available (for example, all items of select list box are displayed etc..)

How it happens : in fact, i tried a nightly build of Mozilla 1.7a (is it happen
whith other nightly build ?) and i use it with my current profil (well, first
error ;-) ). And unfortunately, this version set the
nglayout.debug.use_xbl_forms to true.

Well, if you tried a nightly build (for testing), __test always with new
profil__, or verify nglayout.debug.use_xbl_forms (and set it to false if not),
if you want use another stable version of mozilla with same profil.
Assignee: bryner → nobody
Component: XP Toolkit/Widgets → Layout: Form Controls
QA Contact: jrgmorrison → layout.form-controls
You need to log in before you can comment on or make changes to this bug.