Closed Bug 1856182 Opened 9 months ago Closed 7 months ago

"Never for this site / this language" options should dismiss the translations panel

Categories

(Firefox :: Translations, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
122 Branch
Tracking Status
firefox122 --- fixed

People

(Reporter: Gijs, Assigned: ktumuhairwe24, Mentored)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file, 2 obsolete files)

If I'm changing per-site or per-language translation to never be offered, it's a bit weird that the popup for that site in that language doesn't immediately go away. I assume this is a bug of some kind... but for users who find the feature annoying / where it gets in their way, it's definitely an additional point of frustration when after finding the entry in the cog menu (which is already not super obvious as a place to look for 'turn this off') for it to never show up, it then seems like that "doesn't work" because the panel stays open.

It seems reasonable to me to hide the popup after clicking in the menu items. I know Erik had some thoughts in this space. Should we hide the menu on any menu click, or just some of them? I don't think this is a defect, since I believe this was a deliberate decision. I'll let :nordzilla weigh in here.

Severity: -- → S3
Type: defect → enhancement
Flags: needinfo?(enordin)
Priority: -- → P2

I think we should do this, and I think it would also be a good first bug. I'm going to do a good-first-bug writeup for this today.

This would be a good first bug.

A contributor will likely have to add a new page action called CLOSE_PANEL and adapt the page actions to do this only in the case where never-translate-language and never-translate-site are enabled (not disabled)

https://searchfox.org/mozilla-central/rev/81a006cd60c54ce074d7158fafc5a2923717860e/browser/components/translations/content/translationsPanel.js#22-26

This may break some existing tests which need to be fixed. A contributor should probably add a new telemetry test to ensure that the panel is closed when expected, if they feel that coverage was not sufficient by fixing any broken tests.

https://searchfox.org/mozilla-central/source/browser/components/translations/tests/browser

Flags: needinfo?(enordin)
Mentor: enordin, gtatum
Keywords: good-first-bug

Hi please can i be assigned this bug ?

Hello @Erik Nordin, I hope you are well.
In the code file, the translate-language and the never-translate site compute state basing on binary computations e.g, #computeState(1, 1, 0, 0):
Please help me understand the computations (how they work) in correspondence with a Page Action so that I can determine the correct sequence for when the functions (check boxes) are enabled.
Thank you.

Assignee: nobody → ktumuhairwe24
Status: NEW → ASSIGNED
Attachment #9358645 - Attachment is obsolete: true
Attachment #9359051 - Attachment is obsolete: true
Duplicate of this bug: 1846975
Attachment #9359363 - Attachment description: Bug 1856182 - [broswer about: Translations] Added a CLOSE_PANEL page action to be activated whenever the never-translate language and never-translate site option are enabled or toggled on. r=nordzilla,gregtatum! → Bug 1856182-Ensure the Translations panel closes when a user chooses to never translate. r=nordzilla,gregtatum!
Pushed by enordin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b92137bf5c7
Ensure the Translations panel closes when a user chooses to never translate. r=nordzilla,translations-reviewers
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 122 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: