error in compiling jsdtoa.c when optimizing gcc-3.2 build for pentium4 CPU

VERIFIED DUPLICATE of bug 172618

Status

()

Core
JavaScript Engine
--
major
VERIFIED DUPLICATE of bug 172618
16 years ago
16 years ago

People

(Reporter: daniel, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla 1.3a Source

When compiling using gcc 3.2.1 with -03 -march=pentium4 -mcpu=pentium4, I get
the following error when compiling:

jsdtoa.c: In function `JS_strtod':
jsdtoa.c:1875: unable to find a register to spill in class `AREG'
jsdtoa.c:1875: this is the insn:
(insn:QI 2000 1999 2001 (set (reg:CCNO 17 flags)
        (compare:CCNO (and:SI (subreg:SI (reg/v:DI 21 rxmm0 [285]) 0)
                (const_int 1 [0x1]))
            (const_int 0 [0x0]))) 281 {testsi_1} (insn_list 1996 (nil))
    (expr_list:REG_DEAD (reg/v:DI 21 rxmm0 [285])
        (nil)))
jsdtoa.c:1875: confused by earlier errors, bailing out
make[3]: *** [jsdtoa.o] Error 1


Reproducible: Always

Steps to Reproduce:
1. run ./configure
2. run make

Actual Results:  
make aborted the compilation

Expected Results:  
compilation should have continued normally

using glibc 2.2.5, gcc 3.2.1, kernel 2.4.20

*** This bug has been marked as a duplicate of 172618 ***
Severity: blocker → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
WORKAROUND: Compile this file separately using the same gcc command executed by
make, only with -02 -march=i686 -mcpu=i686 instead of -03 -march=pentium4
-mcpu=pentium4

Comment 3

16 years ago
Verified Duplicate.

daniel: thank you for this report. You have been cc'ed on bug 172618
so you can follow progress on this issue -
Status: RESOLVED → VERIFIED
Summary: error in compiling jsdtoa.c → error in compiling jsdtoa.c when optimizing gcc-3.2 build for pentium4 CPU
You need to log in before you can comment on or make changes to this bug.