Closed Bug 1856929 Opened 7 months ago Closed 5 months ago

Attachment list slow to appear when remote content takes a long time to load

Categories

(Thunderbird :: Message Reader UI, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr115+ fixed, thunderbird120 affected)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr115 + fixed
thunderbird120 --- affected

People

(Reporter: fedkad, Assigned: darktrojan)

References

(Regressed 1 open bug)

Details

(Keywords: perf:responsiveness, regression, Whiteboard: [regression: 115.3.0])

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Steps to reproduce:

Version 115.3.1 (Supernova) of Thunderbird running under x86_64 Ubuntu 23.04 (GNOME) as a normal (apt installed) application has a bug, where for some (?) emails I am unable to view and select an attachment for displaying it.

In the preview pane or in the separate message window (displayed when I double-click on the message) I scroll down to see the list of attachments at the bottom, but nothing is displayed except the main message's contents, as if the message has no attachment(s). So, I am unable to select and view an attachment.

This happens for new or old archived messages. However, some messages do not have this problem and it looks like the reason of displaying or not displaying the attachment section after the end of the message content cannot be determined.

Actual results:

PROBLEM: For some emails, I am unable to select and view an attachment.

WORKAROUND: For those emails, selecting "View » Message Body As » Simple HTML" corrects the problem and the attachment list is displayed at the bottom as it should be. But, "View » Message Body As » Original HTML" hides the attachments again.

Expected results:

For ALL emails with attachment(s), the list of all attachments should be displayed at the bottom of the message window or preview pane, regardless of the "View » Message Body As » ..." option selected.

OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Looks like a variation of bug 1362539. Can you supply a sample of a message where attachments aren't displayed (save as .eml file and attach to the bug). Please replace personal information with xxx in the headers and body.

I do have such a problematic message that contains HTML code plus a PDF attachment. However, when I try to remove some confidential information from the raw EML file's HTML part, the problem no longer appears.

The main structure of the message is something like this:

<<mail headers>>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="=-fWyJfDzo2w/G6LjE64ab1A=="
X-OriginalArrivalTime: 03 Oct 2023 16:05:37.0525 (UTC) FILETIME=[72D0FA50:01D9F613]

--=-fWyJfDzo2w/G6LjE64ab1A==
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable
<<some HTML code>>
--=-fWyJfDzo2w/G6LjE64ab1A==
Content-Type: application/pdf;
	name*=iso-8859-1''xxxx-Eyl%FCl%202023.pdf
Content-Disposition: attachment
Content-Transfer-Encoding: base64
Content-Id: <30xxxd59>

JVBERi0xLjQKJeLjz9MKNCAwIG9iago8PC9Db2xvclNwYWNlL0RldmljZVJHQi9TdWJ0eXBl
<<some base64 code>>
JWlUZXh0LTUuMy4yCnN0YXJ0eHJlZgoxODA2ODcKJSVFT0YK

--=-fWyJfDzo2w/G6LjE64ab1A==--

This same message was displayed correctly with the attachment information in the previous (<=102.x) versions of Thunderbird.

This is a very typical multipart/mixed message, text/html + PDF attachment. There is no reason for the attachment not to display. Without submitting the message, it's impossible to diagnose. The idea was not to remove the confidential information but to replace/obfuscate it. Maybe if a TB dev takes a look, you can send the message to them if you don't want to attach it. (I'm not a developer.)

Attachment #9356857 - Attachment description: I sample EML file exhibiting the problem (sample3.eml). Most of the mail headers removed and the PDF attachment (base64) cropped. → I attached a sample EML file exhibiting the problem (sample3.eml). Most of the mail headers removed and the PDF attachment (base64) cropped.

OK. I attached a sample EML file exhibiting the problem (sample3.eml). Most of the email headers are removed and the PDF attachment (base64) is cropped.

Please,

  • open this file in Thunderbird (version 115.3.1);
  • check that View » Message Body As » Original HTML is selected;
  • do Message » Copy to » your Inbox.
  • If you try to display the message in your Inbox while Remote content is blocked, the attachment section at the bottom of the preview pane will be displayed correctly;
  • However, if you allow Show remote content for this message in Preferences, the attachment section at the bottom will be hidden!
Attached image attachment-display.png

Sorry, I can't see what the problem is meant to be. The attachment is shown in the attachment area as it should be. I tried original/simple HTML and plain text. All good. Maybe some defective add-on is causing a problem here. Let me guess: "Display HTML Temp"?

Please, allow to show remote content for this message. Thanks.

Somehow wires crossed here.

Yes, confirmed: However, if you allow Show remote content for this message in Preferences, the attachment section at the bottom will be hidden!

Please change the bug summary to:
Thunderbird 115.3.1 (Supernova) attachment display problem after displaying remote content in a message.

Summary: Thunderbird 115.3.1 (Supernova) attachment display problem → Thunderbird 115.3.1 (Supernova) attachment display problem after displaying remote content in a message

I guess something in the HTML section (a remote content) disables the display of the attachment section. That is the reason that View » Message Body As » Simple HTML does not have this problem.

Could be a regression of bug 1851871 which was about message display and remote content. Did this already happen in TB 115.2.3?

In 115.2.3 it takes a long time to show the attachment, but it finally arrives. Actually, in 115.3.1 it is also displayed, after about 30 seconds.

Display the message and wait.

Yes! You are right! In my system (both with the original message and with the sample EML file I attached) it took exactly 90 seconds and after that the attachment list was displayed.

Change the summary to:
Attachment list slow to appear when remote content takes long to load (up to 90 seconds).

Flags: needinfo?(geoff)
Summary: Thunderbird 115.3.1 (Supernova) attachment display problem after displaying remote content in a message → Thunderbird 115.3.1 (Supernova) - Attachment list slow to appear when remote content takes long to load (up to 90 seconds)

Bug 1855758 I suppose?

Similar, yes. This bug here has a reproducible case, well, until image server gets faster again.

If it can be of any help: I determined that in my sample EML (that I have attached to the case) it is the server www.csdlabapps.com that is not responding. Replace that address with something invalid and the message will load quickly together with the attachment info displayed at the bottom. So the problem depends on the choice whether to delay displaying attachment info at the end of the message before all remote objects are loaded or not.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1855758
Resolution: --- → DUPLICATE

According to Francesco Occhipinti, the fix for bug 1855758 does not address or fix the problem present in this bug. So, I am reopening it now. More comments can be added by Francesco.

Status: RESOLVED → UNCONFIRMED
No longer duplicate of bug: 1855758
Flags: needinfo?(fo)
Resolution: DUPLICATE → ---

Thanks. Showing the attachment list of the sample e-mail attached above (attachment 9356857 [details]) still takes more than 30 seconds in yesterday's Daily build where the fix of bug 1855758 is included. So this issue here is not fixed by bug 1855758.

Flags: needinfo?(fo)
See Also: → 1855758
Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(geoff)
OS: Linux → Unspecified
Hardware: x86_64 → Unspecified
Keywords: regression
Summary: Thunderbird 115.3.1 (Supernova) - Attachment list slow to appear when remote content takes long to load (up to 90 seconds) → Attachment list slow to appear when remote content takes a long time to load

This isn't ever going to work the way I'd originally intended, so instead I've added a new
nsIMailProgressListener callback for handling attachments as soon as they're available, and will
do everything else on the DOMContentLoaded event.

Severity: -- → S2
Priority: -- → P2
Whiteboard: [regression: 115.3.0]
Target Milestone: --- → 121 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/47d9fa4780d5
Stop using STATE_STOP to trigger message display functions. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago5 months ago
Resolution: --- → FIXED

What is the meaning of "Target Milestone: --- → 121 Branch"?

(In reply to Fedon Kadifeli :fedkad from comment #23)

What is the meaning of "Target Milestone: --- → 121 Branch"?

It was fixed in daily development build, version 121. On Tuesday it shipped as beta 121.0b1. Eventually it will be fixed in 115.

(In reply to Wayne Mery (:wsmwk) from comment #24)

It was fixed in daily development build, version 121. On Tuesday it shipped as beta 121.0b1. Eventually it will be fixed in 115.

Thanks for the explanation. I guess it is still not fixed in https://www.thunderbird.net/en-US/thunderbird/115.5.0/releasenotes/ released yesterday. I will be watching for the newer releases.

Good for 115? If you want longer on beta that's fine too

Flags: needinfo?(geoff)

Comment on attachment 9361778 [details]
Bug 1856929 - Stop using STATE_STOP to trigger message display functions. r=#thunderbird-reviewers

I reckon it's good to go. Not seen any complaints, and I can't think of a reason why it'd be worse than the existing code.

Flags: needinfo?(geoff)
Attachment #9361778 - Flags: approval-comm-esr115?

Comment on attachment 9361778 [details]
Bug 1856929 - Stop using STATE_STOP to trigger message display functions. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9361778 - Flags: approval-comm-esr115? → approval-comm-esr115+
Regressions: 1869499
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: