If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

error checking POP account on startup when % in login name

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Ethan Pooley, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When logging into a POP account on startup where login name is like
address%domain.com, Mozilla Mail presents this error:

The USER command did not succeed. Mail server mail.domain.com responded: POP
service disabled.

When I click the 'Get New Messages' button immediately after this, the login
succeeds and all email is downloaded normally. The error does not recur until I
have closed all instances of all Mozilla components, and then restart Mozilla
Mail. For example, if I close Mail but leave Navigator open, then reopen Mail,
my account is automatically checked and no error is generated. However, the
'quick launch' program alone does not keep the error from recurring; only open
Mozilla components.

Reproducible: Always

Steps to Reproduce:
1. Set up a mail account where login name is like address%domain.com.
2. Have an email server that is expecting this login format (My host is
jumpline.com).
3. Make sure 'check for new messages at startup' is checked.
4. Close all Mozilla components, then open Mozilla Mail.

Actual Results:  
An 'Alert' box appears, saying:

The USER command did not succeed. Mail server mail.domain.com responded: POP
service disabled.

Expected Results:  
Since it sends the info correctly at other times, I assume that it should
succceed and download mail. Other users of the same mail server have NOT
reported this problem with other clients (pegasus, outlook, etc.)
Product: MailNews → Core

Comment 1

13 years ago
Should work with current versions.

Feel free to reopen the bug if you can reproduce the problem with a current
Mozilla build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.