Status

SeaMonkey
General
--
enhancement
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Martin Pagnan, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

I have noticed that numerous sites are now prefering "pop-unders" to 
pop-ups. A "pop-under" appears not when you enter the page or while you 
browse but when you click to leave the page (search "popunder" and "pop-
under" in Google for more details. I believe that an enhancement should
be added to block pop-unders just like the new feature to block pop-ups.

Reproducible: Always

Steps to Reproduce:
1.Exit a page.
2.Pop-under with advertising appears.
3.



Expected Results:  
Pop-unders blocked after the user is given the option, just like blocking
pop-ups.

Comment 1

16 years ago
dup of bug 132031?
Can you provide a testcase or an URL that shows this behaviour.
See also bug 126224.
(Reporter)

Comment 2

16 years ago
I believe that the NYTimes example is different, from the description. As 
I understand it, pop-under ads are a new tool in the web page programmers'
tool-kit. From an expert in this, I have been led to understand that a number
of books are available that show how to put them on your page. One site solicited 
me to include pop-under ads in my web-page; they would somehow randomly pop their
own ad pages up when someone exited my page - and, pay me if the ads then sold
something. To repeat, look up pop-under in Google, you will learn all about
them. Or try this: http://www.javascriptkit.com/script/script2/popunder.shtml
and you will get a Java script on how to create your own pop-unders. Here is a
web site which has been set up to test pop-unders:
http://www.fastclick.com/details/pop-under.html Just go to the site, allow them
to set a cookie, and exit. The pop-under should appear. If it ceases to work,
search Google and you will find a dozen more. Also, you will note that there is
a rising anti-pop-under movement: http://jenett.org/asap/

Comment 3

16 years ago
As far as Mozilla is concerned, blocking popups and popunders is equivalent.
Both work. If you visit pages where you do see popups or popunders (which are
hardly new, and we're well aware of their existence) while you've disabled the
"open unrequested windows" setting, chances are you're running into a workaround
like the one emplyed at the NYT site, and this is thus a dupe.
Echoing comment 1, please provide a url where you see this occurring so we can
look at the javascript used and determine if this is indeed a dupe.
(Reporter)

Comment 4

16 years ago
As the person who submitted this,I would like to cancel it. I have 
confirmed that the pop-up blocking works for pop-unders as well.
However, I believe that a note should be added to the help file
to indicate that a user may have to learn to go back to a browsed
page in order to cancel the pop-under that appears when he exits
the page. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
Not FIXED as there was no change in the code.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

16 years ago
WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.