Closed Bug 1857824 Opened 6 months ago Closed 5 months ago

I can't see my all email panel after Thunderbird update - if prefs.js contained an invalid hostname like "günlükler"

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115+ fixed, thunderbird119 affected, thunderbird121 fixed)

RESOLVED FIXED
122 Branch
Tracking Status
thunderbird_esr115 + fixed
thunderbird119 --- affected
thunderbird121 --- fixed

People

(Reporter: eyaktas, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image thunderbird hata.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36 OPR/102.0.0.0

Steps to reproduce:

I've updated thunderbird to 115.3.1

Actual results:

Thunberbird main mail window doesn't work and some js errors are in the error console. I can't see folders and mail list. I can view emails by clicking by system notification window.

Expected results:

I've atteched ss, error console and errors and all white and not working panel at backside.

Thanks for the great details

Flags: needinfo?(geoff)

Bug 1854064. Or some variation - I don't think we know of all cases where that could happen.

Yasin, if possible, send me a copy of your prefs.js file (or attach to this bug). See https://support.mozilla.org/en-US/kb/profiles-where-thunderbird-stores-user-data for where to find it

It certainly looks like bug 1854064 to me. I reproduced the same errors by removing the host name of an account.

Flags: needinfo?(geoff)

(In reply to Magnus Melin [:mkmelin] from comment #2)

Bug 1854064. Or some variation - I don't think we know of all cases where that could happen.

Yasin, if possible, send me a copy of your prefs.js file (or attach to this bug). See https://support.mozilla.org/en-US/kb/profiles-where-thunderbird-stores-user-data for where to find it

After reading your and Geoff's posts, I've controlled all hostname vars at prefs.js. Found and changed one of hostname which has Turkish chars and thunderbird started to works. (user_pref("mail.server.server7.hostname", "Haber gruplar1 ve günlükler");)

The bug seems about Turkish chars or empty hostnames

Interesting! Any idea how that got into the prefs.js? The UI doesn't allow setting an invalid hostname like that.

I can indeed reproduce the issue when setting the hostname to günlükler! Setting hostname (manually in prefs.js) to other random invalid things, or even hostnames with spaces do not reproduce.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: I can't see my all email panel after Thunderbird update → I can't see my all email panel after Thunderbird update - if prefs.js contained an invalid hostname like "günlükler"

(In reply to Magnus Melin [:mkmelin] from comment #5)

Interesting! Any idea how that got into the prefs.js? The UI doesn't allow setting an invalid hostname like that.

I can indeed reproduce the issue when setting the hostname to günlükler! Setting hostname (manually in prefs.js) to other random invalid things, or even hostnames with spaces do not reproduce.

I think "Haber grupları ve günlükler" is a turkish translate from language file its about RSS and News. Now its again the same sentence but correct utf8 chars and thunderbird works.

Bug is about wrong turkish char codes old .js file.

When coming from an URI, we were looking for xn--gnlkler-n2ac when hostname was günlükler.
Just changing it to use GetDisplayHost worked for some cases, but then there were cases where the URI was nsIMsgMessageUrl and those had the implementation of GetDisplay** wrong.

Status: NEW → ASSIGNED

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ca6caca33867
Make sure server can be found even if the hostname was turned to punycode. r=BenC

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 122 Branch

Comment on attachment 9363983 [details]
Bug 1857824 - Make sure server can be found even if the hostname was turned to punycode. r=BenC

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: may bet blank 3pane
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): not particularly risky, but if something still would turn up it would be problematic.

Attachment #9363983 - Flags: approval-comm-esr115?
Attachment #9363983 - Flags: approval-comm-beta?

Comment on attachment 9363983 [details]
Bug 1857824 - Make sure server can be found even if the hostname was turned to punycode. r=BenC

[Triage Comment]
Approved for beta

Do we want a new bug for "I think relying on any "Display" functions for internal lookups like this isn't a good idea. The implication being that functions with "Display" might return different things depending on locale settings. Don't think that's the case here, but it still smells bad."

Flags: needinfo?(mkmelin+mozilla)
Attachment #9363983 - Flags: approval-comm-beta? → approval-comm-beta+

I don't think that's warranted. This particular "Display" function is not locale dependent.

Flags: needinfo?(mkmelin+mozilla)

Comment on attachment 9363983 [details]
Bug 1857824 - Make sure server can be found even if the hostname was turned to punycode. r=BenC

[Triage Comment]
Approved for esr115

Attachment #9363983 - Flags: approval-comm-esr115? → approval-comm-esr115+
Regressions: 1870720
Regressions: 1872632
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: