Frame contents not shown properly with Mozilla browser. Works fine with Netscape 4.7 and IE

RESOLVED DUPLICATE of bug 181357

Status

()

RESOLVED DUPLICATE of bug 181357
16 years ago
6 months ago

People

(Reporter: herm, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

At the URL given above, there are "Now Playing" links that open up a framed
Pop-up window. The Top window is suppose to show an image and below the image a
three song playlist. Netscape and IE show the playlist correctly, but the
Mozilla browser shows only the Image.

However, if you right-click on the area where the playlist should be and select
"This Frame/Show Only This Frame", then the playlist is properly displayed.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.ElectricBluesRadio.com
2. Click on anyone of the "Now Playing" links
3.

Actual Results:  
Only image is displayed in top frame.

Expected Results:  
A playlist should appear below the image.

Comment 1

16 years ago
changing product to browser from bugzilla
Component: Bugzilla-General → Layout: HTML Frames
Product: Bugzilla → Browser
Version: unspecified → Trunk
reassigning to default owner in the corrected product
Assignee: justdave → frame
QA Contact: matty → amar

Comment 3

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Java script console shows these errors 
===========
Error: uncaught exception: Permission denied to get property Window.css
----------
Error: playlist has no properties
Source File: http://www.live365.com/scripts/mini.js
Line: 484
==========
The top frame runs SetUpPlaylist() in the body part. The last part of
SetUpPlaylist() runs DrawPlaylist(playlist, showBuyButton, showWishButton,
imageDir);.  DrawPlaylist() is in http://www.live365.com/scripts/mini.js .  
Part of DrawPlaylist() is line 484 "DrawPlaylistItem(3, playlist.three,
showButtons, imageDir);"

When you save as a complete page it renders corectly.

NOTE: I'm not a javascript expert 
(Reporter)

Comment 4

16 years ago
I'm a bit confused by the description of the error.  Is there a modification I 
need to make to the main HTML page that sets up the frames, or is the error 
embedded in the URL that is called into the top frame (ie, the URL sourced from 
Live365.com - which of course I have no control over)?

Comment 5

16 years ago
I'm sorry about my description. I know it wasn't the best.  I just hope it helps
someone.

Anyway, I found another website http://www.wizardfkap.com/page5.html that uses
iframes and has the same problem as your site.

Well doing another serach through bugzilla I found bug 181357 which is the same
problem as this one. So this bug is a dupe.

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 181357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

6 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.