misaligned text in rendering of spanish version of hotmail

RESOLVED DUPLICATE of bug 167408

Status

()

Core
Layout: Tables
--
trivial
RESOLVED DUPLICATE of bug 167408
16 years ago
14 years ago

People

(Reporter: Hector Fabio Meza, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

In the spanish version of hotmail, when you look at a message's page, the text
"Versión compatible con la impresora" (Printer compatible version) appears
overlapping a drop-down select ("colocar en carpeta", move to folder). 

This doesn't occur in the english version of hotmail, maybe because texts are
shorter in that version.

It seems to be related to the style sheet, since changing the name of
hotmail___906000056.css to hotmail___906000056.css.bak in the files directory
causes the text to be aligned properly.

Reproducible: Always

Steps to Reproduce:
1. 
2. 
3.
(Reporter)

Comment 1

16 years ago
Created attachment 109535 [details]
message from spanish version of hotmail

This is a message in the spanish version of Hotmail, including css files.

Comment 2

16 years ago
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

Same file displays without overlap in Opera v.6 & 7.

Comment 3

16 years ago
Created attachment 119474 [details]
Stripped down version of original test case

This file contains the minimum HTML/CSS required to duplicate this bug.

Comment 4

16 years ago
By the way, I'm not at all sure this is a CSS issue, it looks more like a
table-layout problem to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Created attachment 119478 [details]
Testcase

After playing a little with that last attachment, I found that the problem
seems to be caused by:

1. The padding in the .pbttn class 

padding-left: 4px;
padding-right: 4px;

If these 2 lines are removed, the text is shown properly.

AND/OR

2. The fixed width of the table 

width="590"

If the width is removed or increased, the page renders correctly.
(Reporter)

Updated

16 years ago
Component: Style System → Layout: Tables

Comment 6

14 years ago
Created attachment 164994 [details]
another testcase

Comment 7

14 years ago
Comment #5 is spot on, the padding is the problem, the new testcase just makes 
it a little more obvious.

*** This bug has been marked as a duplicate of 167408 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.