Closed Bug 18586 Opened 20 years ago Closed 20 years ago

[INC CONTENT SINK] Table layout problems with lxr.mozilla.org

Categories

(Core :: Layout: Tables, defect, P1)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: vidur, Assigned: karnaze)

References

()

Details

Try both http://lxr.mozilla.org and http://lxr.mozilla.org/seamonkey. In both
cases, there are severe layout problems as a result of incremental loading,
including missing frames. Turning off incremental notifications in the content
sink (comment out the call to FlushTags in HTMLContentSink::WillInterrupt())
seems to fix the problems. Note that the content model includes the missing
content and the frame actually exist (but are missized) in the frame model.
Summary: Table layout problems with lxr.mozilla.org → [DOGFOOD] Table layout problems with lxr.mozilla.org
Adding dogfood to summary, since bug 18615 is a dup of this.
*** Bug 18615 has been marked as a duplicate of this bug. ***
*** Bug 18615 has been marked as a duplicate of this bug. ***
Whiteboard: [PDT+]
adding pd+ to status whiteboard, per bug 18615.
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: [DOGFOOD] Table layout problems with lxr.mozilla.org → [INC CONTENT SINK] Table layout problems with lxr.mozilla.org
Whiteboard: [PDT+]
This is temporarily fixed because I reverted nsPresShell.cpp back before the
delayed processing of reflow commands. Please leave this bug open, because
delayed reflow commands will be turned back on. Removing PDT+, DOGFOOD and
adding INC CONTENT SINK.
Target Milestone: M13
Target Milestone: M13 → M14
mass move to m14.
Whiteboard: [MAKINGTEST] bud@silkspin.net
Whiteboard: [MAKINGTEST] bud@silkspin.net
This appears to be fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Keywords: verifyme
Works fine here
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.