Closed Bug 1858629 Opened 6 months ago Closed 5 months ago

invite attendees - clicking on found user adds them twice

Categories

(Calendar :: Calendar Frontend, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr115 --- fixed

People

(Reporter: mozilla, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression, triaged)

Attachments

(2 files)

Attached image error_freebusy.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Steps to reproduce:

I created a new event in Thunderbird 115.3.2 and wanted to invite additional attendees from my address book (synced from LDAP).

Actual results:

When clicking on the attendee in the search list of the free/busy search, the attendee is added twice with an empty row after each entry. When selecting the attendee via keyboard and hitting enter the attendee is added correctly.

Expected results:

The attendee is only added once and the cursor jumps to the next line.

See Also: → 1847493

I see that on Daily as well.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, triaged
Summary: Free/busy search shows multiple entries → invite attendees - clicking on found user adds them twice
Duplicate of this bug: 1858689

To repro in 115.3.2 on Windows 10:

  1. Open Calendar.
  2. New Event.
  3. Invite Attendees.
  4. The author's name is the first in the list. Type "Mickey Mouse" in the second row. Press Enter.
  5. Highlight "Mickey Mouse" and press Backspace or Del.
  6. Type "Donald Duck" in the second row. Press Enter.
  7. "Donald Duck" appears twice: in the second and the third row.

Still present on v115.4.1

We have the same behavior in v115.4.2
(enterprise, people yelling again to get outlook :-( )

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Target Milestone: --- → 121 Branch

Pushed by ikey@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/5a17899135c1
Invite attendees - clicking on found user added them twice. r=leftmostcat

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Comment on attachment 9363678 [details]
Bug 1858629 - Invite attendees - clicking on found user added them twice. r=leftmostcat

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: clicking to add attendee will add it twice
Testing completed (on c-c, etc.): c-c, beta
Risk to taking this patch (and alternatives if risky): fairly safe

Attachment #9363678 - Flags: approval-comm-esr115?
Attachment #9363678 - Flags: approval-comm-beta?
Attachment #9363678 - Flags: approval-comm-beta?

Comment on attachment 9363678 [details]
Bug 1858629 - Invite attendees - clicking on found user added them twice. r=leftmostcat

[Triage Comment]
approved for esr115

Attachment #9363678 - Flags: approval-comm-esr115? → approval-comm-esr115+
Regressed by: 1741566
Regressions: 1874450
Duplicate of this bug: 1850728
See Also: → 1888386
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: