Need a filter by Address Book member that is updated automatically every time I add a new contact

VERIFIED DUPLICATE of bug 162789

Status

MailNews Core
Filters
--
enhancement
VERIFIED DUPLICATE of bug 162789
15 years ago
10 years ago

People

(Reporter: Sirron Davis, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021215
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021215

A very powerful filter for an ordinary or business user would be to send all
mail from users in the address book to inbox, and all other users to spam.

95% of the mail I receive from people not in my address book is unsolicited
spam. And 99% of the mail I receive from people in my address book is important
(or at least wanted) mail. I believe many users have similar email patterns.

I can manually create this filter by typing in every contact into a filter as
follows:
   Match all of the following:

   the Sender isn't friend1@friendlyDomain.com
   the Sender isn't friend2@friendlyDomain.com
    "
    "
    "

   Perform this action:
       Move to folder crap_from_unknown_source on Local Folders


If I have a large contact list it will be very easy to mistype an address. And
When I add a new address to my address book, I then must remember to add it also
to my created filter.

But what if I could create the following filter:
   Match all of the following:

   the Sender "exists in address book" "Personal Address Book"

   Perform this action:
       Move to folder my_friends on Local Folders

 Or if I could create the following filter:
   Match all of the following:

   the Sender "doesn't exist in address book" "Personal Address Book"
   the Sender "doesn't exist in address bood" "Business contacts"

   Perform this action:
       Move to folder crap_from_unknown_source on Local Folders

Now every time I update my Address Books, mail from that contact will be routed
properly without my needing to also update my filter(s).

I think this would be pretty powerful, as I could seperate my address book into
"friends address book" "family address book" "school mates address book"
"business address book" .....

Then by filter I can easily route mail into appropriate folders with the natural
action of adding a new friend, family member, or other contact into the proper
address book.

Most important, I can send mail from anyone not in my address book (or books)
into the "spam" folder.


Reproducible: Always

Steps to Reproduce:
N/A 
this is a request for a feature (see Details)
Actual Results:  
N/A
this is a request for a feature (see Details)

Expected Results:  
N/A
this is a request for a feature (see Details)

It seems like this should be pretty easy to do. Address Books store email
addresses. The filter would just need to test sender existance (or not
existance) in the specified addressbook(s). And of course make some kind of
allowance for upper/lower case differences (so that "aaa@bbbccc.com" is the same
as "Aaa@BbbCcc.com")

Comment 1

15 years ago
it's already in Mozilla 1.3a : you can filter mails with a sender in one of your
addressbooks. But not for the TO and CC headers, though...

*** This bug has been marked as a duplicate of 162789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
marking verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.