LXR Filters out quoted zeros.

RESOLVED FIXED

Status

Webtools
MXR
P3
normal
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: Steve Lamm, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

18 years ago
The following source line is supposed to have a zero (0) in quotes, but lxr
shows it as an empty string.

http://lxr.mozilla.org/seamonkey/source/js/src/jsstr.h#147

I wonder what happened here and I wonder if there are other cases where lxr
shows the wrong string.
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv

Comment 2

17 years ago
*** Bug 103578 has been marked as a duplicate of this bug. ***
Dawn, any status on this?  This makes it kinda hard to read code unless you know
about this bug.... :)
(Assignee)

Comment 4

17 years ago
i'll probably look at this shortly, but it'd help if my lxr patches could get 
reviews...
QA Contact: timeless
(Assignee)

Comment 5

13 years ago
*** Bug 291296 has been marked as a duplicate of this bug. ***
reassigning endico's bugs to default owner
Assignee: endico → chase
(Assignee)

Comment 7

12 years ago
Created attachment 204950 [details] [diff] [review]
don't mistreat strings
Assignee: chase → timeless
Status: NEW → ASSIGNED
Attachment #204950 - Flags: review?(LpSolit)

Comment 8

12 years ago
Comment on attachment 204950 [details] [diff] [review]
don't mistreat strings

>-	unless ($frags[0]) {
>+	unless (length $frags[0]) {

Looks good, and fixes the problem.

Nit: maybe (defined $frags[0] && length $frags[0]) would be better, in case $frags[0] is undefined (assuming it's possible for it to be undefined).

r=LpSolit
Attachment #204950 - Flags: review?(LpSolit) → review+
(Assignee)

Comment 9

12 years ago
Comment on attachment 204950 [details] [diff] [review]
don't mistreat strings

mozilla/webtools/lxr/lib/SimpleParse.pm 	1.2
Attachment #204950 - Attachment is obsolete: true
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
QA Contact: timeless → lxr

Comment 10

9 years ago
Just wondering, why is this patch obsolete?
You need to log in before you can comment on or make changes to this bug.