Closed Bug 1859243 Opened 2 months ago Closed 1 month ago

Use latest version of Babel in the parser worker

Categories

(DevTools :: Debugger, task)

task

Tracking

(firefox121 fixed)

RESOLVED FIXED
121 Branch
Tracking Status
firefox121 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We are using some old version of Babel in the parser worker.
I've seen on Github that some performance fixes have landed after our currently used version.
Unfortunately... migrating to the latest doesn't seem to bring any visible improvement on DAMP:
https://treeherder.mozilla.org/perfherder/comparesubtest?originalProject=try&newProject=try&newRevision=d2b138c9dec0dc920115272992b9762a9b432218&originalSignature=4763542&newSignature=4763542&framework=12&application=firefox&originalRevision=e7bddc6bd6b0a5af5ddf9dff0d8e9fece7cde6ef&page=1&filter=pretty&showOnlyConfident=1

But let's try to bump the version anyway. May be on some other STR it can improve performance.

Also removing "buffer", which looks unused.

For some reason the babel upgrade introduces some failure, but only on try:
https://treeherder.mozilla.org/logviewer?job_id=432594049&repo=try&lineNumber=5498
I'm unable to reproduce locally, even when clearing yarn cache as well as node_modules.

Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e015d8116f7
[devtools] Bump babel versions used by the parser worker. r=devtools-reviewers,bomsy
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch

== Change summary for alert #40041 (as of Wed, 25 Oct 2023 17:44:21 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
13% damp custom.jsdebugger.open-large-minified-file.full-selection.DAMP linux1804-64-shippable-qr e10s fission stylo webrender 5,264.73 -> 4,586.80
11% damp custom.jsdebugger.open-large-minified-file.full-selection.DAMP linux1804-64-shippable-qr e10s fission stylo webrender-sw 5,090.78 -> 4,518.48
7% damp custom.pretty-print.jsdebugger.reload.DAMP linux1804-64-shippable-qr e10s fission stylo webrender 10,992.01 -> 10,256.27
7% damp custom.jsdebugger.pretty-print.reload-and-pause.DAMP linux1804-64-shippable-qr e10s fission stylo webrender 11,201.09 -> 10,461.25
6% damp custom.pretty-print.jsdebugger.reload.DAMP linux1804-64-shippable-qr e10s fission stylo webrender-sw 10,699.88 -> 10,090.90
... ... ... ... ...
2% damp custom.jsdebugger.open-large-minified-file.full-selection.DAMP macosx1015-64-shippable-qr e10s fission stylo webrender-sw 4,293.98 -> 4,189.76

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=40041

You need to log in before you can comment on or make changes to this bug.