plus signs in sidebar or location bar searches are not encoded properly (turn into spaces)

RESOLVED DUPLICATE of bug 178149

Status

SeaMonkey
Search
RESOLVED DUPLICATE of bug 178149
15 years ago
9 years ago

People

(Reporter: Joe M, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.72; Windows 2000) [en] (UNIX)
Build Identifier: 

i use google as my search engine. when searching, either by the sidebar or the
location bar and search button, and the search query includes a + sign (e.g.,
c++), the + is not encoded as %2B, but is left as a +, which is shorthand for a
space. so searching for "c++" would give results for "c  ". searches by the form
on the web page are encoded properly.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 178149 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.