Browser crashes on specific URL, e.g. www.f-secure.com

VERIFIED DUPLICATE of bug 184916

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 184916
15 years ago
13 years ago

People

(Reporter: Rene Barbier, Assigned: asa)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021211
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021211

If I try to open specific pages, like http://www.f-secure.com/, Mozilla crashes,
sometimes generating a core, sometimes not.

Reproducible: Always

Steps to Reproduce:
1.Launch browser
2.Type http://www.f-secure.com/ in URL field
3.

Actual Results:  
Browser crashes, sometimes dumping core.

Expected Results:  
Browser should continue running

Theme was classic

Stack trace is

#0  0xee33376c in NSGetModule ()
#1  0xee33a830 in NSGetModule ()
#2  0xee33cb0c in NSGetModule ()
#3  0xee339d34 in NSGetModule ()
#4  0xee334db4 in NSGetModule ()
#5  0xee336390 in NSGetModule ()
#6  0xee3362b0 in NSGetModule ()
#7  0xef59cea0 in nsInputStreamTee::TeeSegment ()
#8  0xef59cf0c in nsInputStreamTee::WriteSegmentFun ()
#9  0xef5a050c in nsPipe::nsPipeInputStream::ReadSegments ()
#10 0xef59d274 in nsInputStreamTee::ReadSegments ()
#11 0xed5885a0 in NSGetModule ()
#12 0xed57e854 in NSGetModule ()
#13 0xed57c1a0 in NSGetModule ()
#14 0xee2dbee4 in NSGetModule ()
#15 0xee31b5d0 in NSGetModule ()
#16 0xee2db134 in NSGetModule ()
#17 0xee2c8318 in NSGetModule ()
#18 0xef5bc33c in PL_HandleEvent ()
#19 0xef5bc26c in PL_ProcessPendingEvents ()
#20 0xef5bd320 in nsEventQueueImpl::ProcessPendingEvents ()
#21 0xee18470c in _end ()
#22 0xee184320 in _end ()
#23 0xef1f5cac in g_io_unix_dispatch ()
#24 0xef1f79ac in g_main_dispatch ()
#25 0xef1f81dc in g_main_iterate ()
#26 0xef1f83f8 in g_main_run ()
#27 0xef34a98c in gtk_main ()
#28 0xee184c04 in _end ()
#29 0xee1e79ac in _end ()
#30 0x19cb8 in getCountry ()
#31 0x1a6c4 in main ()

Comment 1

15 years ago
There is a website icon, so duplicate of bug 184916 ?
(Reporter)

Comment 2

15 years ago
I can access www.mozilla.org or www.redhat.com without problems, and they
display website icons, or is bug 184916 icon-dependent?

Correction: Please also note that OS is Solaris 2.6
OS: SunOS → Solaris

Updated

15 years ago
Severity: normal → critical
Keywords: crash
Summary: Browser crashes on specific URLs → Browser crashes on specific URL, e.g. www.f-secure.com
the web site icons bug is very easy to test.
disable "edit\preferences\Appearance\[]Show Web Site Icons" and you should not
crash.

We need more informations if you still crash because the stack doesn't contain
symbols.

(Reporter)

Comment 4

15 years ago
The browser doesn't indeed crash if the "edit\preferences\Appearance\[]Show Web
Site Icons" flag is disabled

Comment 5

15 years ago
So, is this bug or not a duplicate of bug 184916 ?

With all those hints, it looks like it is ;-]
(Reporter)

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 184916 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified dupe 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.