Hovering scaled PNG slows down system

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: José Jeria, Assigned: Jim Dunn)

Tracking

({perf})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021217

Mouseover the image of Opera 7, beta 2 on thig page and the cpu usage will go to
100% and cursor will freeze.

http://fileforum.betanews.com/detail.php3?fid=945720329

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

15 years ago

Comment 1

15 years ago
unable to reproduce with my win2k box with today's build (12/20/2002)....
anyone else see this?
(Reporter)

Comment 2

15 years ago
Yes, same here now with build 2002122008, Windows XP.

Comment 3

15 years ago
closing, per comment #1 and #2.
WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
Verified WFM win XP trunk build 2002122608
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

15 years ago
I can reproduce this again with build 2003040708, Windows 2000. 
CPU goes to 100% and cursor freezes. 
Viewing the image is no problem, its when its width and height is set to a lower
dimension when this problem occurs. See URL.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 6

15 years ago
Something else must be going on here, I still don't see this.
-goto url
-put cursor over opera png image
-everything seems fine

Can't think of why anything system related would affect this
if everything is ok if you view the image by itself, just not 
in the page.
(Reporter)

Comment 7

15 years ago
Created attachment 120187 [details]
Screenshot

This only happends when hovering the image. Moving the mouse cursor around the
image is totally ok. 

Also scrolling is choppy when coming to the part with the png image.

Maybe this only affects slower systems? I have a Pentium III, 500 Mhz.

Updated

15 years ago
Blocks: 71668
Keywords: perf

Comment 8

15 years ago
I see this as well with build 2003-04-07-08 on Win2K SP3.

When I move the cursor into and out of the image, it freezes for a fraction of a
second and CPU usage goes up.  Once I'm inside the image, the pointer works just
fine.  I also see the choppy scrolling when the image hits the top/bottom of the
screen.
(Reporter)

Comment 9

15 years ago
Raj, are you on a new or older computer?
Would like to know if this only affects slower systems.

Comment 10

15 years ago
Comment 9 was made from a P4 ~1Ghz (I can't remember the exact number).

I've just tested it from my home machine (Athlon XP 1700+ with 512MB Ram with
Moz 1.2.1) and I can't reproduce it :-(.  It may be processor related.  I get a
small CPU hike (in task manager) but the pointer doesn't freeze and it's not
noticable on screen
(Reporter)

Comment 11

15 years ago
This is not only PNG images, on this url i also get this effect on the image at
the bottom
http://bokil.com/index.php?content=portabella

Not as much as this bugs URL, but you notice when you enter the image.
Same thing here, a big image, that is resized to work as a thumbnail.
(Reporter)

Comment 12

15 years ago
I cant reproduce this with an ati graphic card, maybe this only affects nvidia
cards?

Comment 13

14 years ago
wfm FF 20040307 Win2k, S3 gfx card, shall we mark this WFM ?
(Reporter)

Comment 14

14 years ago
Yes, this WFM now, not the same computer though, but if anybody can reproduce,
please reopen.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.