Closed Bug 1859810 Opened 9 months ago Closed 9 months ago

Bookmark suggestion includes container label before URL with browser.urlbar.switchTabs.searchAllContainers = true

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 120
defect

Tracking

()

VERIFIED FIXED
121 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox118 --- unaffected
firefox119 --- unaffected
firefox120 --- wontfix
firefox121 --- verified

People

(Reporter: ke5trel, Assigned: mseibert)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [sng][search-regression])

Attachments

(2 files)

STR:

  1. Set browser.urlbar.switchTabs.searchAllContainers = true.
  2. Create a "Personal" container tab and visit https://bugzilla.mozilla.org.
  3. Bookmark the site and keep the container tab open.
  4. Create a new tab.
  5. Type "bugz" in the address bar and then press Backspace once.

A bookmark suggestion appears for "Mozilla Bug Tracker" which includes the "Personal" container label immediately before the URL. This is not a "Switch to Tab" item, so there should not be a container associated with the bookmark. The label does not use a chiclet appearance which makes it blend in with the URL.

Regressed by Bug 1479858.

:mseibert, since you are the author of the regressor, bug 1479858, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(mseibert)

we are likely not removing (nor hiding) the container chiclet when reusing the row for another result type. Both results come from the same provider, so we assume they are replaceable (rowCanUpdateToResult() returns true). Whatever updateRow() is doing for the action chiclet, should be done for this (may have something to do with the "has-action" attribute).

Whiteboard: [sng]
Assignee: nobody → mseibert
Flags: needinfo?(mseibert)
Status: NEW → ASSIGNED
Severity: -- → S3
Priority: -- → P2
Whiteboard: [sng] → [sng][search-regression]

Set release status flags based on info from the regressing bug 1479858

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/f27b25aebe91
Bookmark suggestion includes container label before URL with browser.urlbar.switchTabs.searchAllContainers = true.r=mak
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch

The patch landed in nightly and beta is affected.
:mseibert, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox120 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(mseibert)

feature is disabled by default. so no.

Flags: needinfo?(mseibert)

Reproducible on a 2023-10-18 Nightly build on Windows 10.
Verified as fixed on Firefox Nightly 121.0a1 on Windows 10, Ubuntu 22, macOS 12.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: