Stop processing feature after rule-match

VERIFIED DUPLICATE of bug 30081

Status

--
enhancement
VERIFIED DUPLICATE of bug 30081
16 years ago
10 years ago

People

(Reporter: katzlbt, Assigned: naving)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

If you write rules that highlight a message (Label the message) there is no way
to stop processing following rules.

Example:

R1: Subject contains "Seminar" -> label message "work" AND *stop processing*
R2: Sender contains "list" -> move to folder List
    // sort out mailing-lists
R3: To does not contain "myEmail" -> move to folder junk  
    // move most of what's left to junk

My intention is to label a message as work and keep it 
in the inbox even if it was sent from a mailing-list. 
That requires a stop processing feature for R1, otherwise
the message gets labeled, but will be moved anyway.

"Move message" implicitly stops processing as the message is
gone from the current folder.

A similar stop-processing feature exists in Evolution (Linux).


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 30081 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.