All users were logged out of Bugzilla on October 13th, 2018

uncheck and check all buttons of search the internet fail.

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
16 years ago

People

(Reporter: mahjongg, Assigned: bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
If you start the "search the internet function" via the pulldown menu or by
clicking on the search button to the right of the URL field you are presented
with a window that has several optinons .
You can push a button marked "check all" to turn on all the checkmarks next to
the names of the search services (yahoo etc.)
you can scroll up and down to see more services.
However when you push the button "uncheck all" only those checkmarks disappear
that are in the visable area of the list.
If you scroll the area you will see that the other services all still have their
 checkmarks turned on!
Obviously the invisible checkmarks should also have been turned off.

The bug is present in release M10 and the nightly release of 11/11/1999
(Reporter)

Updated

19 years ago
Summary: uncheck all button of search the unternet fails. → uncheck all button of search the internet fails.

Updated

19 years ago
Assignee: shuang → don
Component: UE/UI → Browser-General

Comment 1

19 years ago
Not sure if this is the widget or other type of problems. re-assign it to don.
Assignee: don → trudelle
Component: Browser-General → XP Toolkit/Widgets
Changing to XP Toolkit / Widgets and reassigning.  Could this be a problem with
the tree widget?  (Or with the JS code that manipulates it?)

Updated

19 years ago
Assignee: trudelle → hyatt

Comment 3

19 years ago
reassigning to hyatt for triage.

Updated

19 years ago
Assignee: hyatt → waterson

Comment 4

19 years ago
Dup of the state saving bug in the tree.  I think waterson and nisheeth were
working on that?

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Comment 5

19 years ago
Looks like the problem still exists. RJC, could you verify that the JS stuff is
doing the right thing? Oddly, "Check All" seems to work. It could be a problem
with checkboxes not understanding how to turn themselves off.

Comment 6

19 years ago
I think Hyatt mentioned a long time ago that this is a long-standing bug with
checkboxs (and perhaps other widgets) where they aren't storing their state
properly.

Another example: notice that if you check a search engine, but then scroll it
offscreen, it will not be used when a search happens.

Comment 7

19 years ago
we thought we fixed this.

Comment 8

19 years ago
correction: we thought we fixed this for text fields. specifically using
nisheeth's [Set|Get]ContentID() to ensure that re-frames can find there way
back to content elements.

maybe checkboxes need some love, too? kmcclusk: are you the Barry White for
that job?

Comment 9

19 years ago
This bug may even have been fixed.  It's been floating around for a while.

Comment 10

19 years ago
No, it's still broken.

Updated

19 years ago
Assignee: waterson → rods
Status: ASSIGNED → NEW

Comment 11

19 years ago
rods: this is due to the fact that checkboxes aren't savvy with respect to
remembering their state when frames are destroyed and re-created. I think this
is probably a dup of another bug you have on the internet search dialog.

Updated

19 years ago
Assignee: rods → nisheeth

Comment 12

19 years ago
That isn't what's happening.  The problem is that you're attempting to
query the frame when no frame exists.  In this case, a dummy frame
needs to be made.  Nisheeth should get this.
*** Bug 23492 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: nisheeth → hyatt

Comment 14

19 years ago
Dave, re-assigning to you as you are going to fix this...

Updated

19 years ago
Assignee: hyatt → rjc

Comment 15

19 years ago
I've made it so that offscreen checkboxes will update properly if the ".checked"
property is changed.  I did not fix the bug, however, since RJC is trying to set
the attribute and the property at the same time, and I think is getting out of
sync in places.

It's now a XUL/JS bug in search, so I'm reassigning it to rjc.
Created attachment 4262 [details]
New internet.xul file
Created attachment 4263 [details]
New internet.js file

Updated

19 years ago
Assignee: rjc → hyatt
David, I've checked the xul/js to only set the ".checked" property and still see
the same problem.  [I'm using today's builds on Linux.]

Can you take another look at this?

I've attached the modified XUL/JS files.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M15

Comment 19

19 years ago
moving out.

Updated

19 years ago
Target Milestone: M15 → M16

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 20

19 years ago
jdunn pointed out the problem.  fixed.

Comment 21

19 years ago
this is not fixed at all. it is still broken on all platforms with the 2000020215 builds.
someone may want to look at reeling in the milestone on this one as well. REOPENING
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 22551 has been marked as a duplicate of this bug. ***

Comment 23

19 years ago
blah blah blah
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 24

19 years ago
sigh. this still doesn't work. Sometimes it looks like it does but a little palying shows you that it doesn't. Check off some items, 
scroll to the bottom and check off some more. Now click uncheck. Scroll up to the top and see items still checked.

Do i really need to to write a separate bug for 'check all' ? It's got the same troubles with non-visible elements.
(2000030709 WinNT Build)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 25

19 years ago
rjc, switch over to XUL <checkboxes>. They'll work.  Screw HTML.

Reassigning to robert.
Assignee: hyatt → rjc
Status: REOPENED → NEW
David, I've tried both <html:input type="checkbox"> as well as [XUL] <checkbox> 
and neither seems to 100% correctly.  <sigh>
Assignee: rjc → hyatt

Comment 27

19 years ago
<checkbox> just doesn't have images for the checked state checked in yet.  It 
does actually work.  Bother ben about getting the images checked in.  At any 
rate, you have to eliminate all HTML in this XUL file anyway, so you will need 
to do this work at some point.
Assignee: hyatt → rjc

Updated

19 years ago
Assignee: rjc → ben
OK, I just checked in changes to use [XUL] <checkbox> as well as ".checked".

Ben, the rest is up to you.
erm, the original bug described here appears to have been fixed. do not like 
morphing bugs.  closing. 
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 30

19 years ago
not that I think we should be doing any work on this dialog anyway, but widgets should work. This is REOPENED because the 
original and only reason this bug exists- uncheck/check all button fails to do so is still true.

ALL platforms with 2000032809 builds
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: uncheck all button of search the internet fails. → uncheck and check all buttons of search the internet fail.

Comment 31

19 years ago
oh yeah to get to this dialog select Bookmarks|Manage Bookmarks. Then in the Edit menu for that window select Search 
Bookmarks. In the resulting window, select the Search the internet tab.

Updated

19 years ago
Target Milestone: M16 → M18

Comment 32

19 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
this bug is now invalid, given the fact that the search window is defunct. 
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → INVALID
mass-verifying Invalid bugs which haven't changed since 2001-12-31.

use the search string "PinballWizard" if you want to filter out this msg.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.