weirdness when setting designMode='on' and not in <body onload>

RESOLVED DUPLICATE of bug 207842

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 207842
15 years ago
13 years ago

People

(Reporter: Kathleen Brade, Assigned: Kathleen Brade)

Tracking

({qawanted})

Trunk
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: midas [need testcase])

(Assignee)

Description

15 years ago
Mike Kaply and other Midas users have noticed problems/errors (inability) to set
designMode='on' unless that is done in the load handler for the <body>
(Assignee)

Updated

15 years ago
Whiteboard: midas

Comment 1

15 years ago
I are having problems to, sometimes it fails. Sometimes other setting like
designModeOnFrameDocument.body.style.backgroundColor="#ffff00";
that you make in the same javascript function as designMode="on" does not occur.

It helps to call the initIFrame method with a setTimeOut('initIframe()',100);



Comment 2

15 years ago
To me it seems you cannot set designMode=on before the content document of the
iframe is fully loaded.
(Assignee)

Comment 3

15 years ago
I don't have a testcase for this bug.  I think some of these "weirdnesses"
(elaborated by Anders and Vidar) have been fixed in other bugs (for 1.4final). 
If someone could supply a testcase, that'd be great.  If not, I'll resolve this
bug as invalid.
Status: NEW → ASSIGNED
Keywords: qawanted
Whiteboard: midas → midas [need testcase]

Comment 4

14 years ago
In my opinion, this bug is the same than the <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=207842">bug 207842</a>

Comment 5

14 years ago
Yes, this and bug 207842 are the same issue, that one has several testcases.

Comment 6

13 years ago
duping to newer bug with more info

*** This bug has been marked as a duplicate of 207842 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.