Closed Bug 1860743 Opened 6 months ago Closed 6 months ago

toggle "recently-closed tabs from all windows" set to false shows tabs from closed windows

Categories

(Firefox :: Session Restore, defect, P1)

Firefox 119
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: 73y8f6sj1, Assigned: sfoster)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-firefox-view])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0

Steps to reproduce:

I toggled 'browser.sessionstore.closedTabsFromAllWindows' to 'false'.

Actual results:

In recently closed tabs I see tabs from closed windows.

Expected results:

That I don't see closed tabs from any other window.

The Bugbug bot thinks this bug should belong to the 'Firefox::Session Restore' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Session Restore
Assignee: nobody → sfoster
Blocks: 1850630
Severity: -- → S4
Priority: -- → P1
Whiteboard: [fidefe-firefox-view]

Sorry this was fixed by flipping 'browser.sessionstore.closedTabsFromClosedWindows'. It's not a bug, it's just requires a separated option.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.