Closed Bug 18609 Opened 21 years ago Closed 12 years ago

[BOOKMARKS] need to migrate 4.x bookmarks that are really mailbox:// and IMAP:// urls

Categories

(MailNews Core :: Profile Migration, defect, P3)

x86
All
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: sspitzer, Unassigned)

Details

we need to migrate any mailbox:// urls in bookmarks.

here's an example of a 4.x bookmark:

mailbox:/C|/Program
Files/Netscape/Users/johng/mail/Inbox?id=C32EE7CBC436D21196EA00805FA7F6A60D826B%40ptmsg1.hq.navy.mil&number=16254696&part=1.2

we need to migrate that to

mailbox://johng@nsmail-2/Inbox?id=C32EE7CBC436D21196EA00805FA7F6A60D826B%40ptmsg1.hq.navy.mil&number=16254696&part=1.2

(assuming his mail server is nsmail-2)

we've already got code to convert from the 4.x world to the 5.0 world

see nsMsgAccountManager.cpp

the tricky part is we'll have probably have to migrate the prefs first and right
now, we migrate the prefs when the first mail / news window (including compose)
is opened.
QA Contact: gbush → laurel
marking m20.  accepting.
do you think a lot of people will have this?  I don't think so.
no, this will not be common.
move to future milestone
Target Milestone: M20 → Future
migration bugs to racham
Assignee: sspitzer → racham
Status: ASSIGNED → NEW
Target Milestone: Future → ---
Status: NEW → ASSIGNED
Target Milestone: --- → Future
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
as with bug 45777...
->WONTFIX since 4.x migation has been dropped on trunk. 

If one has an overwhelming need to see this fixed on branch, please attach a patch and reopen the bug.  Also, evaluate whether the issue is a bug or an enhancement request and adjust severity accordingly.
filter bugmail for "4.xmidrop" to delete these messages.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.