Closed Bug 1861000 Opened 6 months ago Closed 6 months ago

TypeError: extraOptions is undefined [@getSharedIdForNode]

Categories

(Remote Protocol :: WebDriver BiDi, defect, P1)

defect
Points:
3

Tracking

(firefox121 fixed)

RESOLVED FIXED
121 Branch
Tracking Status
firefox121 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [webdriver:m9][wptsync upstream][webdriver:relnote])

Attachments

(2 files)

Running the pdf.js Puppeteer integration tests the following failure can be seen:

Suite error: Copy and paste all text
  Message:
    ProtocolError: Protocol error (script.callFunction): unknown error TypeError: extraOptions is undefined getSharedIdForNode@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:480:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:906:40
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeList@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:587:7
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:872:26
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:858:26
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeList@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:587:7
    serializeArrayLike@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:535:24
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:834:12
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serializeMapping@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:650:38
    serialize@chrome://remote/content/webdriver-bidi/RemoteValue.sys.mjs:935:24
    serialize@chrome://remote/content/webdriver-bidi/modules/WindowGlobalBiDiModule.sys.mjs:72:34
    #buildReturnValue@chrome://remote/content/webdriver-bidi/modules/windowglobal/script.sys.mjs:163:34

The problem is actually when calling serializeList() for a Set or a Map.

It might be good to check other lines as well.

Blocks: 1770725
Summary: Protocol error (script.callFunction): unknown error TypeError: extraOptions is undefined getSharedIdForNode → TypeError: extraOptions is undefined [@getSharedIdForNode]
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Points: --- → 3
Priority: -- → P1
Whiteboard: [webdriver:m9]
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/195c5e117bfc
[webdriver-bidi] Always pass extraOptions when serializing a remote value. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/ba013fa64048
[wdspec] Improve WebDriver BiDi tests when serializing nodes within an Array, Map, or Set. r=webdriver-reviewers,jdescottes
Whiteboard: [webdriver:m9] → [webdriver:m9], [wptsync upstream error]
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/42802 for changes under testing/web-platform/tests
Whiteboard: [webdriver:m9], [wptsync upstream error] → [webdriver:m9], [wptsync upstream]
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch
Upstream PR merged by moz-wptsync-bot
Whiteboard: [webdriver:m9], [wptsync upstream] → [webdriver:m9][wptsync upstream][webdriver:relnote]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: