Crash on close after going to any URL by typing URL to the location bar and that URL triggers matches in the history

VERIFIED DUPLICATE of bug 156940

Status

--
critical
VERIFIED DUPLICATE of bug 156940
16 years ago
10 years ago

People

(Reporter: jsluoma, Assigned: hewitt)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB15271943G, DUPEME(156940)?)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021218
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021218

TB ID: TB15271943G, TB15268530G



Reproducible: Always

Steps to Reproduce:
1. Type some URL to the location bar that triggers some matches in the history.
Go to that URL.
2. Close the browser.


Actual Results:  
Crash.

Expected Results:  
Clean close.

Extract from drwtsn32.log:

State Dump for Thread Id 0x51c

eax=026b27bc ebx=020f3ea8 ecx=026b27a0 edx=61745008 esi=026b27a0 edi=02669b14
eip=61741b26 esp=0012fcf0 ebp=0012fdd0 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00200206


function: <nosymbols>
        61741b05 66817e08644e     cmp     word ptr [esi+0x8],0x4e64 
ds:0328fd73=????
        61741b0b 754d             jnz     6174a65a
        61741b0d 8b5c2410         mov     ebx,[esp+0x10]        
ss:00d0d2c3=????????
        61741b11 8b7e2c           mov     edi,[esi+0x2c]        
ds:0328fd72=????????
        61741b14 83662c00         and   dword ptr [esi+0x2c],0x0
ds:0328fd72=????????
        61741b18 53               push    ebx
        61741b19 e88607ffff       call    617322a4
        61741b1e 85ff             test    edi,edi
        61741b20 c6460c73         mov     byte ptr [esi+0xc],0x73     
ds:0328fd72=??
        61741b24 7448             jz      6174546e
FAULT ->61741b26 397704           cmp     [edi+0x4],esi         
ds:032470e6=????????
        61741b29 7410             jz      6174833b
        61741b2b 68ac717461       push    0x617471ac
        61741b30 e8b30fffff       call    61732ae8
        61741b35 397704           cmp     [edi+0x4],esi         
ds:032470e6=????????
        61741b38 59               pop     ecx
        61741b39 7533             jnz     61749e6e
        61741b3b 83670400         and    dword ptr [edi+0x4],0x0
ds:032470e6=????????
        61741b3f 83663000         and   dword ptr [esi+0x30],0x0
ds:0328fd72=????????
        61741b43 8bd3             mov     edx,ebx
        61741b45 83c328           add     ebx,0x28
        61741b48 f7da             neg     edx

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
0012FCF8 61741448 020F3EA8 026B27A0 6174146F 020F3EA8 mork!<nosymbols>  (FPO:
[1,0,3])
0012FD04 6174146F 020F3EA8 026B27A0 61741490 0205A3F0 mork!<nosymbols>  (FPO:
[1,0,1])
0012FD10 61741490 0205A3F0 61732123 00000001 61DF9040 mork!<nosymbols>  (FPO:
[0,0,1])
0012FD18 61732123 00000001 61DF9040 026B27B8 619066F2 mork!<nosymbols>  (FPO:
[1,0,1])
0012FD20 61DF9040 026B27B8 619066F2 02760990 0205A3F0 mork!<nosymbols>  (FPO:
[1,0,0])
0012FD28 619066F2 02760990 0205A3F0 619066CB 02760990
xpcom!nsCOMPtr_base::~nsCOMPtr_base  (FPO: [0,0,0])
0012FD34 619066CB 02760990 61906804 00000001 61DB77F9 appcomps!<nosymbols> 
(FPO: [0,0,2])
0012FD3C 61906804 00000001 61DB77F9 0205A3F0 02760990 appcomps!<nosymbols> 
(FPO: [1,0,1])
0012FD44 61DB77F9 0205A3F0 02760990 61DB73FD 02760990 appcomps!<nosymbols> 
(FPO: [1,0,0])
0012FD50 61DB73FD 02760990 02760990 02760990 61DB2B82
xpcom!nsSupportsArray::Clear  (FPO: [1,0,1])
0012FD60 61DB2B82 02760994 000000F4 61DB7243 00000001
xpcom!nsSupportsArray::DeleteArray  (FPO: [0,0,2])
0012FD7C 61DF9040 02760990 619068E5 020D3B00 020D3B00
xpcom!nsSupportsArray::operator=  (FPO: [EBP 0x61DB7243] [1,0,4])
0012FD84 619068E5 020D3B00 020D3B00 619068B7 00FFA614
xpcom!nsCOMPtr_base::~nsCOMPtr_base  (FPO: [0,0,0])
0012FD90 619068B7 00FFA614 61906804 00000001 610CA598 appcomps!<nosymbols> 
(FPO: [0,0,2])
0012FD98 61906804 00000001 610CA598 020D3B00 00000001 appcomps!<nosymbols> 
(FPO: [1,0,1])
0012FDA0 610CA598 020D3B00 00000001 614347F8 00000000 appcomps!<nosymbols> 
(FPO: [1,0,0])
61DB7243 550004C2 8B53EC8B DB85105D 03B80775 EB800040 xpc3250!<nosymbols> 
5E5FC033 00000000 00000000 00000000 00000000 00000000 <nosymbols>

Updated

16 years ago
Keywords: crash, stackwanted
Whiteboard: TB15271943G

Comment 1

16 years ago
Additional information:
This only happens if you mouse or key to the URL in the dropdown.  Typing in the
complete URL without choosing it from the list does *not* trigger this crash on
shutdown.  Also, going to other pages in the interim seems to fix whatever
causes the crash to occur.  My guess would be that this was caused by the
checkin that modified autocomplete heuristics.  In any case, it's annoying. :) 
I'm not sure this is the right component, but URL Bar makes more sense than
Browser-General. :)

(And I'm on WinXP, FWIW.)
Status: UNCONFIRMED → NEW
Component: Browser-General → URL Bar
Ever confirmed: true

Comment 2

16 years ago
Oops.  Not for Asa. :)
Assignee: asa → hewitt
QA Contact: asa → claudius
dupe of topcrash 156940? 

cc'ing for talkback
Whiteboard: TB15271943G → TB15271943, DUPEME(156940)?
oops, sorry, accidently killed the G from the end of that ID. my bad =/
Whiteboard: TB15271943, DUPEME(156940)? → TB15271943G, DUPEME(156940)?

Comment 5

16 years ago
I don't think this is a dupe of bug 156940.  This did not occur in 1.3a.  It's a
regression from sometime after that branched.

Comment 6

16 years ago
Created attachment 110297 [details]
history.dat which shows this error

This doesn't happen in all cases.  Something special has to happen to your
history file.  I don't know if it takes actual corruption, or if something else
triggers it.  But I delete my history.dat as a workaround when it crashes, then
after an hour or so of use, the file has what it take to crash Mozilla again.

To reproduce with this file, exit Mozilla, copy this history.dat file into your
profile, relaunch, and start to type in www.ozyandmillie.org.  When
autocomplete comes up, press tab, then enter.  Wait for it to load, then close
Mozilla.  It should then crash.

Comment 7

16 years ago
Stupid question: does this have anything to do with url-data.txt?
Created attachment 110369 [details]
stack from talkback incident TB15271943G
duping, ccing these users in other bug.

*** This bug has been marked as a duplicate of 156940 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.