SetTextboxFocus() should select textbox contents

RESOLVED FIXED in mozilla1.3final

Status

SeaMonkey
Composer
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
mozilla1.3final
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
Now that bug 118038 is fixed we can restore .select() to SetTextboxFocus()
(Assignee)

Comment 1

15 years ago
Created attachment 109736 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

15 years ago
Attachment #109736 - Flags: superreview?(kin)
Attachment #109736 - Flags: review?(cmanske)

Updated

15 years ago
Attachment #109736 - Flags: review?(cmanske) → review?(brade)

Comment 2

15 years ago
Comment on attachment 109736 [details] [diff] [review]
Proposed patch

remove the commented out lines for textbox.focus and textbox.select
r=brade
Attachment #109736 - Flags: review?(brade) → review+

Comment 3

15 years ago
-->Neil since it is his patch and cmanske is vacationing
Assignee: cmanske → neil
OS: Windows 95 → All
Hardware: PC → All

Comment 4

15 years ago
Comment on attachment 109736 [details] [diff] [review]
Proposed patch

sr=kin@netscape.com

Just adddress brade's issues above.
Attachment #109736 - Flags: superreview?(kin) → superreview+
(Assignee)

Comment 5

15 years ago
Comment on attachment 109736 [details] [diff] [review]
Proposed patch

Technically this fixes a regression of bug 103197
Attachment #109736 - Flags: approval1.3b?
(Assignee)

Updated

15 years ago
Keywords: regression

Comment 6

15 years ago
Neil, are you aware of bug 124750?
textbox.focus() is e.g. responsible for chatzilla's focus stealing when new
channels are joined.
I just want to make sure that this fix does not cause a new focus stealing bug...
(Assignee)

Comment 7

15 years ago
Andreas, SetTextboxFocus already sets focus (duh!), but without selecting.

Comment 8

15 years ago
Oh, sorry, I misread the patch... (there is a confusing number of comments...)
(Assignee)

Comment 9

15 years ago
Now I know why brade wants them removed :-)

Comment 10

15 years ago
Comment on attachment 109736 [details] [diff] [review]
Proposed patch

We're trying to get 1.3beta out the door. This is going to have to wait.
Attachment #109736 - Flags: approval1.3b? → approval1.3b-
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3final
(Assignee)

Updated

15 years ago
Attachment #109736 - Flags: approval1.3?

Comment 11

15 years ago
Comment on attachment 109736 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to 1.3 final.
Attachment #109736 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 12

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.