All users were logged out of Bugzilla on October 13th, 2018

Consistent wizard screen titles

VERIFIED FIXED in M14

Status

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: bijals, Assigned: robinf)

Tracking

other
x86
Windows NT

Details

(Reporter)

Description

19 years ago
For more than one wizard page for a certain type of customization, we use "Part
One", "Part Two", and so forth as shown in the "Customizing the Browser" pages.
However, the "Customizing Internet Setup" pages do not follow this consistent
methond.  Instead, we have "Customizing Internet Setup - Points of Presense
(PoPs)" as one page and "Customizing Internet Setup" as the second one.

I recommend that we change the Internet setup pages to be "Part One" and "Part
Two" respectively.

Also, we have differences between "Customizing Installer" and "Building the
Installer(s)" is?  Not sure why one is singular and one is plural.  Also, the
"Building" the installer is not building anything until you hit BUILD.  How can
we make this more consistent?  "Customizing the Installer - Part One" and
"Customizing the Installer - Part Two"?

Updated

19 years ago
Assignee: selmer → robinf
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M12
(Assignee)

Comment 1

19 years ago
Here are my proposed changes to the wizard banner text on each screen. Please
review them. Once we've finalized them,
I'll send the new text to Gemma.

Screen 1: Welcome to the Netscape Client Customization Kit (CCK)!
Screen 2: Gathering Information (unchanged)
Screen 3: Customize the Netscape Browser - Part One
Screen 4: Customize the Netscape Browser - Part Two
Screen 5: Customize the Netscape Browser - Part Three
Screen 6: Customize the CD Autorun Screen
Screen 7: Customize Internet Setup - Part One
Screen 8: Customize Internet Setup - Part Two
Screen 9: Customize the Installer
Screen 10: Create the Installer
(Reporter)

Comment 2

19 years ago
I am fine with the changes below except I have a comment on "Netscape Client
Customization Kit".  Would we call this "Netscape Client Customization Kit
Tool"?  Sounds odd with tool after CCK.
(Assignee)

Comment 3

19 years ago
Have sent this text to Gemma so she can create new banners.
(Assignee)

Updated

19 years ago
Depends on: 20251
Target Milestone: M12 → M13
(Assignee)

Comment 4

19 years ago
Updating bug dependencies. Gemma has sent us the new banners (see
http://Blues/users/bijals/publish/cck/UIFeedback/cckartworklst.htm). I won't
check them in until Bug 20251 is resolved, since we may have to ask Gemma to
reduce the widths of the banners if bug 20251 can't be fixed.

Comment 5

19 years ago
Need to change the titlebar numbering from page numbering to groupings by
customizable section.  Making this change will eliminate the chance that users
may get confused after they deselect the CD Autorun checkbox and notice that the
titlebar numbering skips page 6. (as discussed with Bijal, and Robin)

Welcome screen title bar should be changed to state: "Netscape Client
Customization Kit 5.0 - Welcome"

Gathering Information screen's title bar should  be changed to state: "<config>
Netscape Client Customization Kit 5.0 - Gathering Information"

Customize the Browser - Part One, Two, and Three screens' title bars should be
changed to state: "<config> Netscape Client Customization Kit 5.0 - Browser 1 of
3" "Browser 2 of 3", and "Browser 3 of 3" respectively.

Customize the CD Autorun Screen's title bar should be changed to state:
"<config> Netscape Client Customization Kit 5.0 - CD Autorun"

Customize Internet Setup - Part One, and Part Two screens' title bars should be
changed to state:
"<config> Netscape Client Customization Kit 5.0 - Internet Setup 1 of 2" (we may
want to consider renaming "Internet Setup" to "Dialup Profile")

Customize the Installer screen's title bar should be changed to state: "<config>
Netscape Client Customization Kit 5.0 - Installer"

Create the Installer screen's title bar should be changed to state: "<config>
Netscape Client Customization Kit 5.0 - Create Installer"
(Reporter)

Comment 6

19 years ago
What if we just removed the numbering in the title bar that says x out of 10?
Now the end user will not get confused since s/he does not know that there were
a total of 10 screens.  I thought giving this x out of 10 would at least
indicate that this is not a never ending wizard.

Also, I do not see the need to put "Netscape Client Customization Kit 5.0" on
all banners as well as the configuration name.
(Assignee)

Comment 7

19 years ago
*** Bug 6344 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

19 years ago
*** Bug 6344 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

19 years ago
Expect to have fixes checked-in by M13 deadline. Moving TFV to M14 since it's
not a "stopper".
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14

Comment 10

19 years ago
This bug was vandalized by a clueless idiot.  I believe I have undone all of the
vandalism.
(Assignee)

Comment 11

19 years ago
Marking fixed. Please take a look at Tuesday's build (2/15/00) and let me know 
if further changes are needed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 12

19 years ago
Marking this Verified Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.