font anti-aliasing weight/hinting changes with window size

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
P2
normal
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Jason Clinton, Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When resizing the window, certain window sizes result in different font
hinting/anti-aliasing for the exact same fonts. I have attached two screen shots
in PNG format below for verification. Notice the changes only affects the bold
fonts in the Slashdot headings and sub-headings. I have no idea what could be
causing this. The font sizes on this page are expressed in absolute measurments.

Reproducible: Always

Steps to Reproduce:
1. Browse anywhere with text.
2. Resize the window.
3. Watch the fonts change their weight/hinting.

Actual Results:  
Fonts get uglier/less aliased when the window is larger.

Expected Results:  
Be consistent.
(Reporter)

Comment 1

16 years ago
Created attachment 109764 [details]
These fonts look better/more smooth.
(Reporter)

Comment 2

16 years ago
Created attachment 109765 [details]
These fonts look more harsh.
(Reporter)

Updated

16 years ago
Version: Trunk → Other Branch

Updated

15 years ago
Priority: -- → P2

Comment 3

14 years ago
I'm unable to reproduce this with 1.7 beta and the latest trunk nightly build on
windows XP. I don't see any differences at different window sizes in the "meta
moderated?" font at slashdot.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.