Title and pop-up menus and multiple displays

RESOLVED DUPLICATE of bug 138933

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 138933
16 years ago
14 years ago

People

(Reporter: Matthew Litwin, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

In XP, when you have multiple displays running in "attached" mode, and you are
using the browser in a secondary monitor, and you select any menu, the menu
contents pops up in the primary menu in the upper left corner, as opposed to
under the menu title where you would expect. Basically, menus only pop up
properly when Mozilla window is in the primary window only. Note this is an IBM
thinkpad where both displays run off the same video controller (Super Savage).

Reproducible: Always

Steps to Reproduce:
Assuming you have displays in "attached" mode:
1. Open a browser window and move it into the desktop of the secondary display
2. Select any title or bookmark menu
3. You may be wondering where the menu is that you just selected- it is !
Actual Results:  
Menu pull down appears in the upper left corner of the primary display.

Expected Results:  
It should appear under its menu title.

Comment 1

15 years ago
I can reproduce this bug under XP and a newer build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

All menus opened on the secondary display pop up on the primary display.

The problem does NOT occur if the video driver handles the display spanning
itself: ie, a configuration where Windows thinks it has a single display of
2048x768, but the driver breaks that up onto two monitors, each running at
1024x768 resolution.  However, if you configure the driver to run as "TwinView"
(where Windows knows it has multiple displays, and is explicitly told which
display is the primary one), this is the situation where the problem occurs.

I'm using a Leadtek A250, which is a dual-headed nVidia video card.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 138933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.