Closed Bug 18620 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Reply to a message in a Local Mail folder doesn't fill in the address or subject correctly

Categories

(MailNews Core :: Composition, defect, P3, major)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: esther, Assigned: bugzilla)

Details

(Whiteboard: [PDT+] 11/29)

Using build 1999111017 on win and linux and 1999111011 on mac when I click Reply
to a message in a Local Mail folder, the compose window comes up but the reply
to address is not filled in nor is the title of the message visible on the
subject line after  Re: I found this when verifying the fix for 17956, could
that bug fix be related to this one.

1. Launch Messenger (create an IMAP account so you automatically have a Local
Mail account too)
2. Copy or Move a message into a Local Mail folder
3. Select the message in that Local Mail folder and click Reply

Result:  Reply compose window comes up but the Address in not automatically
filled in and the message titles is missing from the Subject line after the Re:

Expected: Reply compose window to come up, with the reply to address filled in
and the title of the message displayed after the Re: in the subject line.

Note: bug 17956 was for the body missing, the body is there in this case and
that bug was verified as fixed.
Status: NEW → ASSIGNED
adding ducarroz to the cc list.

accepting.
QA Contact: lchiang → esther
Summary: Reply to a message in a Local Mail folder doesn't fill in the address or subject correctly → [DOGFOOD] Reply to a message in a Local Mail folder doesn't fill in the address or subject correctly
Whiteboard: [PDT+]
Putting on PDT+ radar.
Whiteboard: [PDT+] → [PDT+] 11/17
Target Milestone: M12
will try to fix this tomorrow or the wed.
Blocks: 18951
Whiteboard: [PDT+] 11/17 → [PDT+] 12/3
moving to 12/3, won't be able to fix this for 11/17
Is this only the Mac?  This just worked for me on Windows.
This was on all platforms.
esther will be in Wednesday and can show you (if the problem is still
reproducible for her)
This worked for me on Windows but didn't work for me on the Mac.
Assignee: sspitzer → ducarroz
Status: ASSIGNED → NEW
I am willing to take care of this one...
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] 12/3 → [PDT+] 11/29
fixed by ducarroz. r=sspitzer
Using linux build 1999113008m12 this is fixed, still waiting for Win32 and mac
build to finish verification.
Using build 1999113010m12 on mac (mozilla build) this is fixed.  Still waiting
for win32 build before I can verify this.
Status: RESOLVED → VERIFIED
Using win32 build dated 1999113012m12 this is fixed.  Now verified on all
platforms.
No longer blocks: 18951
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.