IMAP: Sent mail saving bug

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: mozilla.bugzilla.2012, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

After sending mails, sent mails in sent-folder on an IMAP account get destroyed:
Mozilla saves the new sent mail into another mail, which already is in sent-folder.

Reproducible: Sometimes

Steps to Reproduce:
1. Write an email with an IMAP-Account, make sure that there are mails in
sent-folder and sent mails are saved after sending
2. send your email
3. wait until your email has been saved in sent-folders
Actual Results:  
The sent mail does not appear in sent-folder. It actually is there, but the mail
is attached to another mail which was in this folder before.

Expected Results:  
Mozilla should have saved the sent mail as a independent mail in sent-folder

I was using imap.gmx.net als IMAP server.
(Assignee)

Comment 1

16 years ago
are you saying that the sent mail folder on the imap server is corrupted? This
sounds like a server bug. There shouldn't be any way the imap client can corrupt
folders on the server.

Could you try generating an imap protocol log?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Created attachment 109914 [details]
IMAP Logfile

I added the IMAP-Logfile.
I think its a problem of Mozilla as it works correctly with Outlook Express 6.
(Assignee)

Comment 3

16 years ago
that log looks fine. Can you show us a log for retrieving the corrupt message(s)
from the sent mail folder?
(Assignee)

Comment 4

16 years ago
when you say outlook express works fine, do you mean it can read the messages
correctly, or puts them in the sent mail folder without corrupting the sent mail
folder? Does outlook express read the messages correctly?
(Reporter)

Comment 5

16 years ago
Created attachment 109915 [details]
IMAP Logfile retrieving corrupt Message

Outlook Express saves the mail correctly, but if I open a corrupted mail with
Outlook Express it is shown incorrectly.
(Assignee)

Comment 6

16 years ago
this still looks like a server problem - it's possible we're giving the server
the wrong message size, and confusing the server into corrupting the mailbox,
but I haven't heard of any other problems like this. Could you show a log of two
messages getting appended to the sent folder, and then the log of retrieving the
first one?

Note that the server seems to think that message is larger than 6K! - 235 FETCH
(UID 235 RFC822.SIZE 6484 BODY[] {6484}  when it's more like 450 bytes.

Updated

16 years ago
QA Contact: huang → gchan
(Reporter)

Comment 7

16 years ago
Bug seems to be fixed in 1.3a (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.3b) Gecko/20030210), bug doesn't occur anymore since I'm using this.

Comment 8

14 years ago
=>WFM per reporter's comment 7.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.