Mozilla freezes shortly after mail startup

RESOLVED DUPLICATE of bug 186204

Status

SeaMonkey
General
--
blocker
RESOLVED DUPLICATE of bug 186204
15 years ago
13 years ago

People

(Reporter: beanladen, Assigned: asa)

Tracking

Other Branch
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Sparc Solaris 8; en-US; rv:1.2.1)

After starting Mozilla, mailnews comes up (start mailnews at launch on),
then Mozilla freezes without starting a browser window.


Reproducible: Always

Steps to Reproduce:
1. start Mozilla
2. just watch...
3.

Actual Results:  
Mailnews/Mozilla freezes

Expected Results:  
bring navigator window after mailnews and work !


1.1 worked like a charm, rthis build is just unusable. Anyone out there
to donate the usual quality builds ?
(Reporter)

Comment 1

15 years ago
Argh ! The new 'advanced' bug report form is just dull and dumb as straw !!!
Platform is Solaris 8 on Sparc, version 1.2.1 (the one donated by Sun).

OS: other → Solaris
Hardware: Other → Sun
Version: Trunk → Other Branch

Comment 2

15 years ago
Have your read the README in the installation directory. It clearly states that
with this Sun supported version of Mozilla you need GTK libraries that are
compiled with Sun Forte compiler. Because you are able to start the Mozilla you
most probable just have GTK libraries that are compiled with Gnu gcc/g++
compilers. This kind of combination gives unpredictable results and leads for
example the kind of situation you now have faced. I had very similar problems,
before I read the README and used GTK libraries from the Netscape 7.0
distributioon of Sun.

PLEASE follow the instructions in the README file and get the Sun Forte compiled
GTK libraries one of the ways told in the file. After that just add to mozilla
startup script in Mozilla's installation directory following line:

LD_LIBRARY_PATH=/my/location/of/Forte/compiled/gtk/lib:${LD_LIBRARY_PATH};
export LD_LIBRARY_PATH

For example if you have Netscape 7.0 installed to directory /opt/NS/7.0 then the
above line would be something like:

LD_LIBRARY_PATH=/opt/NS/7.0/dist/lib::${LD_LIBRARY_PATH};export LD_LIBRARY_PATH

This starts to be such a FAQ now-a-days that this had to be mentioned on the
release 1.2.1 download web page.

*** This bug has been marked as a duplicate of 186204 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
No. The /opt/sfw/lib path where the GTK libraries are located is provided by Sun 
with their operating system. We don't have anything on our systems that is gcc-
compiled. I even suspect that we don't have gcc at all.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.