Filtering rules seem not stored correctly so change at next run of Mozilla making filters unuseable

VERIFIED DUPLICATE of bug 183158

Status

MailNews Core
Filters
--
critical
VERIFIED DUPLICATE of bug 183158
15 years ago
10 years ago

People

(Reporter: Andreas Troschka, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

While creating (or changing) a filter for Inbox, after saving the filter, the
rule(s) should not change (obviously).
In this Mozilla rev (and I notice this only in this rev) after a restart some
rules are changed causing execution of filters with unwanted rules.

Reproducible: Always

Steps to Reproduce:
1.Start creation of a new message filter: Tools/Message Filter/New
2.Select in the appropriate rule's fields: "Status", "is", "Read"
3.Select in the appropriate action's fields: "Move to Folder", "Trash" (it can
be any other folder)
4.Click on [OK]
5.Close the message Filters Dialog
6.Quit the entire Mozilla apps (Navigator, Composer, Mail etc.)
7.Restart Mozilla mail
 

Actual Results:  
Opening again the Message-Filter/Filter-Rules box, the rule fields now show:
"Status", "is", "Replied" (instead of the selected "Read") and the filter acts
consequently.

Replied messages are trashed instead of Read ones.

This malfunction, in some cases/rules-combinations, may cause unexpected loss of
data (messages).  

Expected Results:  
Mozilla should not make autocton changes in the rules fields.

Any further attempt to correct the filters has no different result.
The Mail Filters are unuseable.

Comment 1

15 years ago
There is an existing bug about Status criteria...  will look up the bug number.

Comment 2

15 years ago
Didn't find the original issue I'm thinking of, but this is a duplicate of bug
183158

*** This bug has been marked as a duplicate of 183158 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.