Closed Bug 1862247 Opened 6 months ago Closed 5 months ago

Quick filter button on the toolbar is disabled when viewing search results as a list

Categories

(Thunderbird :: Toolbars and Tabs, defect, P3)

Thunderbird 115

Tracking

(thunderbird_esr115? fixed, thunderbird121 fixed)

RESOLVED FIXED
122 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird121 --- fixed

People

(Reporter: helder, Assigned: welpy-cw)

Details

Attachments

(2 files)

Attached image quick_filter_button.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/119.0

Steps to reproduce:

First I've place a "Quick Filter" button on the toolbar. Then I did a global search, got some results back and then clicked on "Show results as list".

Actual results:

The Quick Filter button I have placed on the toolbar is disabled, however the button that's on the "Message List Header" remains functional.

Expected results:

Both buttons should be functional.

Found this because I wanted to hide the "Message List Header" (losing the message count, unfortunately).

Tested this both on the stable release and on the daily release (121.0a1).

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED
Target Milestone: --- → 121 Branch
Target Milestone: 121 Branch → 122 Branch

Pushed by ikey@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/b527489c1bd2
Enable Quick Filter unified toolbar button for synthetic views. r=freaktechnik,ikey

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Good for beta?

Flags: needinfo?(h.w.forms)

Comment on attachment 9361485 [details]
Bug 1862247 - Enable Quick Filter unified toolbar button for synthetic views. r=freaktechnik

[Approval Request Comment]
Risk to taking this patch (and alternatives if risky): very low

Flags: needinfo?(h.w.forms)
Attachment #9361485 - Flags: approval-comm-beta?

Comment on attachment 9361485 [details]
Bug 1862247 - Enable Quick Filter unified toolbar button for synthetic views. r=freaktechnik

[Triage Comment]
Approved for beta

Attachment #9361485 - Flags: approval-comm-beta? → approval-comm-beta+

Good for 115?

Flags: needinfo?(h.w.forms)

Comment on attachment 9361485 [details]
Bug 1862247 - Enable Quick Filter unified toolbar button for synthetic views. r=freaktechnik

Yes, I think so!

Flags: needinfo?(h.w.forms)
Attachment #9361485 - Flags: approval-comm-esr115?

Comment on attachment 9361485 [details]
Bug 1862247 - Enable Quick Filter unified toolbar button for synthetic views. r=freaktechnik

[Triage Comment]
Approved for esr115

Attachment #9361485 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: