Help Index should have an entry for "tooltips"

VERIFIED FIXED in mozilla1.8beta1

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: bugz743, Assigned: prometeo.bugs)

Tracking

Trunk
mozilla1.8beta1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

In the "Preferences|Appearance" there is a check box for "Show Tooltips".
However, I cannot find Tooltips in the Help. 



Reproducible: Always

Steps to Reproduce:
1. Open Help.  
2. Choose "Search"
3. Type in "Tooltips". 
4. Hit Enter. 

Actual Results:  
No information about Tooltips is displayed. 

Expected Results:  
Displayed some information about what a Tooltip is.

Comment 1

16 years ago
-> rudman
Assignee: oeschger → rudman
Blocks: 187558
Status: UNCONFIRMED → NEW
Component: Help → User
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Documentation
QA Contact: tpreston → stolenclover
Hardware: PC → All
Summary: No results when searching for "tooltips" in Help → Help Index should have an entry for "tooltips"
Version: Trunk → unspecified

Comment 2

15 years ago
Nilson? Interested in taking this?

Comment 3

15 years ago
Yea, I will.  What do I need to do?  Explain what a tooltip is, and when it will
display?

Comment 4

15 years ago
Created attachment 132107 [details]
First proposal

See if it's the correct syntax, etc. and how it is.

Comment 5

15 years ago
hmm. Not sure about what help file to attach this to. I'll see tomorrow. If
anyone has any suggestions, feel free to post them.

Comment 6

15 years ago
If you'll notice, I took out the unneccesary <a NAME=""> tags and replaced them
with id="" in the h2s.  It serves the same purpose and is cleaner.

Hope that's OK.

Comment 7

15 years ago
-> Nilson
Assignee: rudman → mozbugz

Comment 8

15 years ago
*NOTE*: Adding to cs_nav_prefs_apperance.html

Comment 9

15 years ago
--> me

I misinterpreted this bug. This is a request to add an entry to the index about
Tooltips.

This is in the wrong component. Moving this to Browser: Help
Assignee: mozbugz → rlk
Component: User → Help
Product: Documentation → Browser
Target Milestone: --- → mozilla1.6alpha
Version: unspecified → Trunk
I don't know if we want some mention of it or not, but there is also the
distinction for tooltip of them NOT being displayed for ALT attributes on HTML
elements, only for TITLE attributes.

See bug 25537 for more info.  I know it's controversial, but it may save someone
filing a DUP in the future.

Just a thought.

Updated

15 years ago
Target Milestone: mozilla1.6alpha → mozilla1.7alpha

Comment 11

15 years ago
> I don't know if we want some mention of it or not, but there is also the
> distinction for tooltip of them NOT being displayed for ALT attributes on HTML
> elements, only for TITLE attributes.

This is end-user documentation. We don't want to have developer issues in the 
Help documentation.

I'll come up with a patch for this soon, since it looks like a quick fix.
Status: NEW → ASSIGNED

Comment 12

15 years ago
(In reply to comment #11)
> > I don't know if we want some mention of it or not, but there is also the
> > distinction for tooltip of them NOT being displayed for ALT attributes on HTML
> > elements, only for TITLE attributes.
> 
> This is end-user documentation. We don't want to have developer issues in the 
> Help documentation.
> 
> I'll come up with a patch for this soon, since it looks like a quick fix.

Looking forward to it! ;-)

Comment 13

14 years ago
Moving to new Help component owner.
Assignee: rlk → neil.parkwaycc.co.uk
Status: ASSIGNED → NEW
(Assignee)

Comment 14

14 years ago
Adding tooltip to index is easy: but where should it point to?
cs_nav_prefs_appearance.xhtml doesn't really explains what a tooltip is, and
there is no entry in the glossary for it. Should we add the item to glossay and
add the index entry pointing to it?

Comment 15

14 years ago
I think the Index entries just points to info in the help files, but not to the
glossary.
Product: Browser → Seamonkey

Comment 16

14 years ago
We don't want to put "tooltip" in the index, it's only mentioned in one
particular place. What we can do is to add an explanation to the glossary and
point to that in the appearance prefs text.
(Assignee)

Comment 17

14 years ago
Created attachment 172810 [details] [diff] [review]
As Stefan said (checked in)
Attachment #172810 - Flags: superreview?(bugzilla)
Attachment #172810 - Flags: review?(bugzilla)

Comment 18

14 years ago
Reassigning, also changing target milestone per discussion with Giacomo on irc.
Assignee: neil.parkwaycc.co.uk → giacomo.magnini
Target Milestone: mozilla1.7alpha → mozilla1.8beta

Updated

14 years ago
Attachment #172810 - Flags: superreview?(bugzilla)

Updated

14 years ago
Attachment #172810 - Flags: review?(bugzilla) → review+

Comment 19

14 years ago
Comment on attachment 172810 [details] [diff] [review]
As Stefan said (checked in)

sr=me if you feel you need it ;-)

Comment 20

14 years ago
Comment on attachment 172810 [details] [diff] [review]
As Stefan said (checked in)

Checking in cs_nav_prefs_appearance.xhtml;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/cs_nav_prefs_appearance
.xhtml,v  <--  cs_nav_prefs_appearance.xhtml
new revision: 1.23; previous revision: 1.22
done
Checking in glossary.xhtml;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/glossary.xhtml,v  <-- 
glossary.xhtml
new revision: 1.36; previous revision: 1.35
done
Attachment #172810 - Attachment description: As Stefan said → As Stefan said (checked in)
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 21

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.