CSS height value of the object element is not corretly interpreted, when the object is inside a div

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Klaus Bolwin, Assigned: dbaron)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a) Gecko/20021212

using the following style sheet declarations:

div.window {position:absolute; height:48%; width:48%; right:1%; bottom:1%;
border:inset ThreeDFace; overflow:hidden;}
#f1 {width:100%; height:100%;}

and the following HTML code

<div class="window">
<object id="f1" data="inset.html" type="text/html"></object>
</div>

the height of the object element is not set to 100% of the divs height, but it
is related to window.innerHeight.
This problem occured since the release of Mozilla 1.2 alpha, it worked fine in
Mozilla 1.1 and earlier releases.

setting 
#f1 {width:100%; height:48%;}
will lead to the desired result, but is no solution, because then the page is
displayed incorrectly in other browsers.

Placing the object element outside the div will lead to a correct height,
however then the scroll bars are displayed (if necessary), but don't work.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Created attachment 109829 [details]
html including css example of problem

Comment 2

16 years ago
Mozilla 1.3a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Windows 2000 SP3

works for me, the f1 element completely fills the div.
Worksforme, although perhaps there's something more to the testcase than what's
stated on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.