get error 'Please enter a valid hostname' while trying to establish a new account as well as in the smtp account settings

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: mmay, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

If I try to enter a new account, or try to change the smtp server, I always get
the error 'Please enter valid hostname'. I have the mailserver (mail) in my pop
as well as in the smtp settings, and mozilla 1.3 does not seem to like this.
With 1.2 it worked perfectly. I still can fetch mails without any problems. The
problem occurs as soon as i try to change the host settings or entering new
account settings.

Reproducible: Always

Steps to Reproduce:
1. Add Account
2. Enter Data
3. As soon as I enter the server data and type 'Okay' the error message pops up

Actual Results:  
nothing

Expected Results:  
added a new account 

Well, probably the problem is, that i am using 'mail' as a hostname for one
account as well as the smtp server. But now I cannot change this :-(
When I understand you right the hostname of your hostname is "mail"?
So here we go :): In 
http://lxr.mozilla.org/mozilla/source/mailnews/base/prefs/resources/content/amUtils.js#39
there is the funktion that checks your hostname AFAIK:
 39 function hostnameIsIllegal(hostname)
 40 {
 41   // XXX TODO do a complete check.
 42   // this only checks for illegal characters in the hostname
 43   // but hostnames like "...." and "_" and ".111" will get by
 44   // my test.  
 45   var validChars = hostname.match(/[A-Za-z0-9.-]/g);
 46   if (!validChars || (validChars.length != hostname.length)) {
 47     return true;
 48   }
 49 
 50   return false;
 51 }

Updated

16 years ago
QA Contact: huang → gchan

Comment 3

16 years ago
reporter are you still having this problem?

Does this occur with a new profile?

At the Account wizard screen entitled Server Information:
 -you click radio button Pop
 -for Incoming server: you type 'mail' ?
 -at the bottom of the screen (if you have set up a previous
  mail acnt) you should see some text displaying your outgoing
  smtp server. Is it the correct one?

 The only time I see your 'Please enter valid hostname' mesg is when
 I fail to enter a server name for 'incoming server'. Not for
 smtp server. I can enter anything for Incoming server and it will
 accept it.

I'm not quite sure I am understanding your problem clearly.

In your last statement:
>Well, probably the problem is, that i am using 'mail' as a hostname for one
>account as well as the smtp server. But now I cannot change this :-

Have you thought about removing the acnt and trying again?
Or Editing Server Name (that field is editable) or going
to Outgoing Server Pref and changing server name to another name?

Reporter: are you still having this problem?
(Reporter)

Comment 5

16 years ago
This problem does not occure anymore. I am running now an updated version, so
the bug seems to be fixed (running currently 1.4a).
Ok Resolving Workforme
Reporter. Thanks for your bugreport (also i couldn't find the error here) :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.