Style settings on COL tags are not applied to their corresponding table cells.

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Mike Hall, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020826

See the sample page. Given a table with this COLGROUP:

<colgroup>
	<col />
	<col style="display:none;" />
	<col />
</colgroup>

The third cell in each row should be hidden from view. This does not happen in
Mozilla (tested on 1.2.1). Other style settings, such as "color," also fail to
be applied to the appropriate table cells.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
If I'm reading the W3C spec. right, styles defined on COLGROUP or COL tags
should be applied to their corresponding cells in a table.

Comment 1

15 years ago
>If I'm reading the W3C spec. right, styles defined on COLGROUP or COL tags
>should be applied to their corresponding cells in a table.

IMHO, thats the biggest flaw of the CSS2 spec that exactly this is not the case.
http://www.w3.org/TR/2002/WD-CSS21-20020802/tables.html#q4 if you want to hide
the column use the visibility as shown in the spec. If you have problems with
the visibilty tag they may be caused by bug 77019.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.