Closed Bug 18630 Opened 20 years ago Closed 20 years ago

nszip.exe crashes after selecting build installers

Categories

(CCK Graveyard :: CCK-Wizard, defect, P3, critical)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bmartin, Assigned: vparthas)

Details

Latest CCK build dated: 11-11-99

O/S: WinNT4.0

1-Launch CCK
2-select Default Configuration
3-Proceed through each screen making appropriate customizations
4-Select last Build Installer button on last screen.

Results:

Application Error has Occurred... nszip.exe Exception:access
violation(0xc0000005, Address: 0x77f22d3f
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
11/16 build did not display this problem in general.
Status: RESOLVED → VERIFIED
No loger experiencing this.

Marking this Verified as of latest CCK build dated: 12-02-99
Status: VERIFIED → REOPENED
reopening....

Latest CCK build dated: 12-10-99

nszip.exe crashes after selecting Build Installers on WinNT4.0

System and Stack Trace Info:

Application exception occurred:
        App: nszip.dbg (pid=144)
        When: 12/10/1999 @ 14:59:52.465
        Exception number: c0000005 (access violation)

*----> System Information <----*
        Computer Name: BMARTIN-NT
        User Name: Administrator
        Number of Processors: 1
        Processor Type: x86 Family 6 Model 7 Stepping 2
        Windows Version: 4.0
        Current Build: 1381
        Service Pack: 5
        Current Type: Uniprocessor Free
        Registered Organization: Netscape Communications
        Registered Owner: Brenton Martin

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
0012f8e8 77f226c0 00136f40 00000000 00c06f1b 001367e0
kernel32!EndUpdateResourceA
0012f90c 77f2284a 00000000 001367e0 00136f40 00000409 kernel32!UpdateResourceW
0012f944 00401567 00000000 0042a0f4 00c06f10 00000409 kernel32!UpdateResourceA
0012f980 00401615 00c06f10 00000000 0042a0b8 00000020 nszip!<nosymbols>
0012fcdc 0040112f 00c06e81 0042b880 0042b880 ffffffff nszip!<nosymbols>
0012ff08 004011ac 0042b880 00414c6d 00000000 00000000 nszip!<nosymbols>
0012ff10 00414c6d 00000000 00000000 7ffdf000 0040c067 nszip!<nosymbols>  (FPO:
[0,0,1])
0012ff20 0040c067 00400000 00000000 00132e14 00000005 nszip!<nosymbols>  (FPO:
[4,0,3])
0012ff34 004050b0 00400000 00000000 00132e14 00000005 nszip!<nosymbols>  (FPO:
[4,0,0])
0012ffc0 77f1ba06 00000000 00000000 7ffdf000 c0000005 nszip!<nosymbols>
0012fff0 00000000 00404fd0 00000000 000000b0 00000100
kernel32!GetProcessPriorityBoost
00000000 00000000 00000000 00000000 00000000 00000000 nszip!<nosymbols>

*----> Raw Stack Dump <----*
0012f8d4  1b 6f c0 00 e0 67 13 00 - 00 00 00 00 04 00 00 00  .o...g..........
0012f8e4  b0 cb 0b 00 0c f9 12 00 - c0 26 f2 77 40 6f 13 00  .........&.w@o..
0012f8f4  00 00 00 00 1b 6f c0 00 - e0 67 13 00 58 84 da 00  .....o...g..X...
0012f904  0a 00 00 00 44 f9 12 00 - 44 f9 12 00 4a 28 f2 77  ....D...D...J(.w
0012f914  00 00 00 00 e0 67 13 00 - 40 6f 13 00 09 04 00 00  .....g..@o......
0012f924  30 ca da 00 e1 0f 00 00 - 30 ca da 00 c2 45 00 00  0.......0....E..
0012f934  14 00 16 00 40 6f 13 00 - 0a 00 0a 00 10 6f c0 00  ....@o.......o..
0012f944  80 f9 12 00 67 15 40 00 - 00 00 00 00 f4 a0 42 00  ....g.@.......B.
0012f954  10 6f c0 00 09 04 00 00 - 30 ca da 00 e1 0f 00 00  .o......0.......
0012f964  20 0d c1 00 88 6e 13 00 - 20 0d c1 00 c2 45 00 00   ....n.. ....E..
0012f974  20 0d c1 00 2c 00 00 00 - d9 0f 00 00 dc fc 12 00   ...,...........
0012f984  15 16 40 00 10 6f c0 00 - 00 00 00 00 b8 a0 42 00  ..@..o........B.
0012f994  20 00 00 00 c0 69 fe cb - 61 43 bf 01 00 00 7a 8e   ....i..aC....z.
0012f9a4  e4 42 bf 01 00 dd a3 40 - 62 43 bf 01 00 00 00 00  .B.....@bC......
0012f9b4  c2 45 00 00 00 00 00 00 - 00 00 00 00 63 6f 6e 66  .E..........conf
0012f9c4  69 67 2e 69 6e 69 00 00 - 00 00 00 00 00 00 00 00  ig.ini..........
0012f9d4  00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00  ................
0012f9e4  00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00  ................
0012f9f4  00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00  ................
0012fa04  00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00  ................
Resolution: WORKSFORME → ---
this problem is caused by occasional bad builds of nszip in seamonkey and since
it is random there is no proper solution for this.
Varada, your comment doesn't make sense to me.  Are you saying you can't
reproduce the problem at all?  If you can, reproduce it on a debug build in look
into why it's crashing.  Get help from Sean Su if you need to.
Assignee: selmer → varada
Status: REOPENED → NEW
Bad comments and misleading ones at that- pleading jet lag of two hours for lack
of any better excuse.
The last time I spoke to sean su he told me that someone else had changed
certain files in xpinstall and that was causing the problem - I assume that this
would be the same case and I am going to use the debug version and verify to
make sure and  will bring this problem to sean's notice and try to resolve this
for good.
Status: NEW → ASSIGNED
Target Milestone: M13
This problem was created because of the nsinstall.exe being read only in its
properties.The solution is to make sure that when we zip the files the nsinstall
is zipped without the read only checkbox being checked in its properties.
Am not marking this as fixed till we see a build that can goes thru without this
problem.
marking milestone as M13
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Marking as fixed - tested it on debug as well as frank's build.
Reopen and DIE! :-)
Status: RESOLVED → VERIFIED
Marking this Verified Fixed latest CCK build dated 12-21-99....(so I don't die)
You need to log in before you can comment on or make changes to this bug.