If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

empty apple icards, Apple icard attachment comes up blank

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: hc hennings, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Use Yahoo mail test account: user=mozdebug pwd=mozilla ], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Apple icard attachment comes up blank.
Using yahoo email, when I receive an apple icard (see http://www.mac.com/), the
attachment where my icard should be is blank. Netscape 6.2.3 gives the yahoo
icard as expected (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3). Lots of things are involved with this issue,
but keeps things interesting.

Reproducible: Always

Steps to Reproduce:
1. need a yahoo mailbox 
2. go to http://www.mac.com/ to select and send apple icard to yahoo mailbox
3. open and retrieve apple icard

Actual Results:  
The apple icard comes as attachment, but mozilla responds with whitespace
attachment.

Expected Results:  
mozilla should respond with icard attachment.

Comment 1

15 years ago
Not JavaScript Engine. Reassigning to Browser-General until we can 
get further information. The site WORKSFORME using Mozilla trunk
binary 2002121908 on WinNT. I successfully mailed an iCard from
http://www.mac.com to a test mail account at http://mail.yahoo.com:
          
                      mozdebug@yahoo.com

Login: mozdebug
Pwd  : mozilla


In fact, I left the iCard in the mozdebug mailbox at Yahoo.                                                                                      
hchennings@yahoo.com: what do you see if you login to the test
account at Yahoo and open that iCard? Is it blank?

If not, could you send an iCard to this test account that shows
the problem? Let us know when you have sent it, and I'll check.

Note: I see you're using a 1.2.1 build. We had some problems with
the 1.2.x builds; if you get a chance, please try a trunk build
and see if that fixes things; thanks -
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → asa
Whiteboard: [Use Yahoo mail test account: user=mozdebug pwd=mozilla ]
(Reporter)

Comment 2

15 years ago
The apple icard attachment valid at 
          
                      mozdebug@yahoo.com

Login: mozdebug
Pwd  : mozilla

I forwarded my blank apple icard to mozdebug@yahoo.com for your inspection.
Happy Holidays.

Comment 3

15 years ago
hchennings@yahoo.com: thanks, the message you forwarded is indeed empty.
If it wouldn't be too much trouble, though, could you send an iCard
directly to the test account mozdebug@yahoo.com (i.e. not via forwarding)?

That will help us see what's going wrong; thanks -
(Reporter)

Comment 4

15 years ago
A new apple icard to the test account at mozdebug@yahoo.com using the same
version of mozilla. I sent the same card to myself and it comes up white.

Comment 5

15 years ago
Thanks! I'm using Mozilla trunk 2002121908 on WinNT4.0

When I log into http://mail.yahoo.com, and open that email, I see the
message,  "This iCard has been sent to you from hchennings@yahoo.com",
and underneath it I see a miniature iCard showing a cat wearing a crown.
When I click on that, I get the full-sized version.

I wonder what's going wrong for you. What setting do you have in
Edit > Preferences > Privacy & Security > Images? I have that set to
"Accept all images".

If that isn't it, you can create a new Mozilla profile by launching
Mozilla from a console window like this:

      [(path to Mozilla)] ./mozilla -profilemanager

Once the Profile Manager comes up, click on "Create Profile". I'm 
wondering if the problem goes away if you run Mozilla under a 
brand-new profile.


If that isn't it, can you see if you are getting any errors
in Tools > Web Development > JavaScript Console?

Also, it would be good to try a trunk build when you get a chance,
in case this bug is specific to the 1.2.1 branch you're using -
(Reporter)

Comment 6

15 years ago
I can oclick on up the white attachment and go to View > PageInfo > Media Tab
and see the cat with a crown icard with message "test". Nothing under the
JavaScript Console at first glance. Exactly what am I looking for? I still need
to download the newest build of mozilla and check the status of the icard.
Netscape 6.2 shows icard attachment of cat with a crown as expected.

Good Luck and Happy Holidays.

Comment 7

15 years ago
> Exactly what am I looking for?

The way to use Tools > Web Development > JavaScript Console is to
open it up and make sure "All" is the selected option at upper-left.
(i.e. it should be highlighted in white).

Then hit "Clear" to clear all stale errors which may exist from 
other sites. 

Then try the site in this bug and see if any messages or errors
appear in the JavaScript Console. If any do, please copy them
and paste them into this bug; we might be able to figure out 
what's going wrong that way.


I take it that you do have the Images preference set to
"Accept all images", then?

Also, I'm wondering if a new Profile fixes things - thanks.
(Reporter)

Comment 8

15 years ago
JavaScript cosole has same message twice:
Error: element has no properties
Source File: chrome://cookie/content/cookieNavigatorOverlay.xul
Line: 128

What else can I do?

Comment 9

14 years ago
hc hennings: Are you still having this problem with Yahoo and apple iCards? It's
been about 9 months since you filed this bug, have you tried things out on a
more recent Mozilla build and/or profile? Did you confirm that you're accepting
all images as Phil asked? Thanks for any new information.

Comment 10

14 years ago
Closing as WFM, it's been nearly a year without further confirmation that this
bug exists. If anyone can reproduce it in a recent build, and it isn't obviously
IE-specific coding, please feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.