Chimera hangs on attempted page load Cache folder contains 7,121 files

RESOLVED FIXED

Status

Camino Graveyard
General
--
critical
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Thomas Trevorrow, Assigned: gordon)

Tracking

({hang})

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

I cannot load any web page if Cache folder contains 7,121 files nor can I empty
cache from within preferences. Either activity causes infinite spinning rainbow
cursor. Files must be manually removed from Cache in the Finder in order to
enable Chimera to load web pages again.

Reproducible: Always

Steps to Reproduce:
This is the longest period of time I've used Chimera as my primary web browser.
It will take a long time to attempt to reproduce bug because I have to let my
Cache build up to 7,121 files.

1. Use Chimera for several weeks.
2. If Cache folder exceeds 7,121 files and can still load web pages, then this
is not a reproducable bug.
3.

Actual Results:  
Spinning rainbow pizza without end.

Expected Results:  
Load web page.

Comment 1

15 years ago
What OS version are you using?

Comment 2

15 years ago
Reporter says 10.2.3
(Assignee)

Comment 3

15 years ago
Chimera 0.6 is missing changes to the disk cache that greatly reduce the number
of files used to store data.  The changes were landed on the trunk back in August.

Comment 4

15 years ago
Reporter's build appears to be post-August.
Severity: normal → critical
Keywords: hang
Summary: Can't load any web page if Cache folder contains 7,121 files → Chimera hangs on attempted page load Cache folder contains 7,121 files
(Assignee)

Comment 5

15 years ago
Yes, but Chimera branched before that, so it hasn't picked up the latest changes
yet.

Comment 6

15 years ago
what is the the status of this bug now that chimera has landed on the trunk?
(Assignee)

Comment 7

15 years ago
Taking bug...
Assignee: saari → gordon
(Assignee)

Comment 8

15 years ago
Now that Camino is on trunk, it would be nearly impossible under typical usage
to aquire 7,121 files in the cache directory.  Also, we delete the files much
more efficiently when clearing the cache, and it gets done on a separate thread
so it doesn't block the UI.

Marking FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.