Breadth differs by <INPUT TYPE="text" SIZE="x"> and <INPUT SIZE="x" TYPE="text">.

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: nivoside, Assigned: peterv)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.3a) Gecko/20021220 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021220

A size element will be disregarded when referred to as <INPUT SIZE="x" TYPE="text">.
It seems that width is always interpreted as 20.

Being ignored if the turn of an element becomes reverse is troubled.
It should be interpreted exactly.

A problem occurs after 2002-12-17-08-trunk.
2002-12-17-04-trunk has no problem.

Reproducible: Always

Steps to Reproduce:
A page with the following HTML is opened:

<HTML><BODY>
<FORM><INPUT TYPE="text" SIZE="32"></FORM>
<FORM><INPUT SIZE="32" TYPE="text"></FORM>
</BODY></HTML>
Actual Results:  
The width of two input field differs.

Expected Results:  
The width of the two input fields is the same.
(Reporter)

Comment 1

16 years ago
Created attachment 109858 [details]
The sample of HTML.

Comment 2

16 years ago
WFM 2002121008/NT4

Maybe need to clean xul.mfl / compreg.dat stuff?

Comment 3

16 years ago
Created attachment 109864 [details]
testcase

Well, I'm seeing this problem on Win98 and MacOS9.
Attaching Testcase.
Is this only a problem with the themed controls on Windows?
> A problem occurs after 2002-12-17-08-trunk.
> 2002-12-17-04-trunk has no problem.

peterv, this is when your DOM2 HTML stuff landed...  Could the changes to 
GetSize/SetSize be the problem here?
(Assignee)

Comment 6

16 years ago
Ah, hmm. That could be, yes. The problem is that the unit for the size is
dependent on the type of the input. My code looks at the type when the size
attribute's value gets set, but we probably don't know the type (yet).
I'm away on holiday for two weeks, I'll try to look at it but if anyone wants to
take this, please do. 
well, confirming and to peter for now...
Assignee: form → peterv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.3b?
OS: Windows XP → All
Hardware: PC → All
*** Bug 187494 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
Although the problem had occurred also by Phoenix before, it is repaired
temporarily?

Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.3a) Gecko/20030115 Phoenix/0.5

Comment 10

16 years ago
When viewing the testcase in attachment 109864 [details], I see the differences of sizes
under Gecko/20030112 Phoenix/0.5, XP Pro SP1.
The testcase in attachment 109864 [details] WFM under Mozilla 1.3b 2003011713, XP Pro SP1.
(Assignee)

Comment 11

16 years ago
This looks fixed to me, probably by the fix for bug 188872.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Flags: blocking1.3b?
You need to log in before you can comment on or make changes to this bug.