[CRASH] mozilla -installer crashes

VERIFIED FIXED

Status

P3
blocker
VERIFIED FIXED
19 years ago
3 years ago

People

(Reporter: sspitzer, Assigned: norrisboyd)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

norris, this looks it might be you.

remove ~/.mozilla
run ./mozilla -installer
crash.

it is reproducable.

here are a couple stack traces:
#0  0x32 in ?? ()
#1  0x40a1f1b5 in nsChromeProtocolHandler::NewChannel (this=0x81c4638,
verb=0x8051c5b "load", uri=0x82b07e0, aGroup=0x8180988,
eventSinkGetter=0x81f53c0, originalURI=0x0, result=0xbfffecd8) at
nsChromeProtocolHandler.cpp:166
#2  0x4058c771 in nsIOService::NewChannelFromURI (this=0x812a378, verb=0x8051c5b
"load", aURI=0x82b07e0, aGroup=0x8180988, eventSinkGetter=0x81f53c0,
originalURI=0x0, result=0xbfffed40) at nsIOService.cpp:233
#3  0x804d537 in NS_OpenURI (result=0xbfffee2c, uri=0x82b07e0, aGroup=0x8180988,
eventSinkGetter=0x81f53c0) at nsNeckoUtil.cpp:69
#4  0x40a5dcbc in nsDocumentBindInfo::Bind (this=0x8114660, aURL=0x82b07e0,
aLoadGroup=0x8180988, postDataStream=0x0, aReferrer=0x0) at nsDocLoader.cpp:1078
#5  0x40a5c618 in nsDocLoaderImpl::LoadDocument (this=0x8297348, aUri=0x82b07e0,
aCommand=0x40a75614 "view", aContainer=0x82e9aa0, aPostDataStream=0x0,
aExtraInfo=0x0, aType=0, aLocalIP=0, aReferrer=0x0) at nsDocLoader.cpp:513
#6  0x40a65342 in nsWebShell::DoLoadURL (this=0x82e9aa0, aUri=0x82b07e0,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aType=0, aLocalIP=0,
aReferrer=0x0) at nsWebShell.cpp:2204
#7  0x40a65811 in nsWebShell::LoadURI (this=0x82e9aa0, aUri=0x82b07e0,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aModifyHistory=1, aType=0,
aLocalIP=0, aHistoryState=0x0, aReferrer=0x0) at nsWebShell.cpp:2280
#8  0x40a665cd in nsWebShell::LoadURL (this=0x82e9aa0, aURLSpec=0xbffff674,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aModifyHistory=1, aType=0,
aLocalIP=0, aHistoryState=0x0, aReferrer=0x0) at nsWebShell.cpp:2472
#9  0x40a645c3 in nsWebShell::LoadURL (this=0x82e9aa0, aURLSpec=0xbffff674,
aPostDataStream=0x0, aModifyHistory=1, aType=0, aLocalIP=0, aHistoryState=0x0,
aReferrer=0x0) at nsWebShell.cpp:2031
#10 0x403feeea in nsWebShellWindow::Initialize (this=0x8297180, aParent=0x0,
aShell=0x813c2a8, aUrl=0x81c6a78, aCreatedVisible=1, aLoadDefaultPage=1,
aCallbacks=0x0, aInitialWidth=1, aInitialHeight=1, widgetInitData=@0xbffff75c)
at nsWebShellWindow.cpp:440
#11 0x403fcf77 in nsAppShellService::JustCreateTopWindow (this=0x8128640,
aParent=0x0, aUrl=0x81c6a78, aShowWindow=1, aLoadDefaultPage=1,
aChromeMask=4094, aCallbacks=0x0, aInitialWidth=1, aInitialHeight=1,
aResult=0xbffff81c) at nsAppShellService.cpp:648
#12 0x403fce02 in nsAppShellService::CreateTopLevelWindow (this=0x8128640,
aParent=0x0, aUrl=0x81c6a78, aShowWindow=1, aLoadDefaultPage=1,
aChromeMask=4094, aCallbacks=0x0, aInitialWidth=-1, aInitialHeight=-1,
aResult=0xbffff81c) at nsAppShellService.cpp:583
#13 0x804ab7e in OpenChromURL (urlstr=0x8050aae "chrome://navigator/content/",
height=-1, width=-1) at nsAppRunner.cpp:292
#14 0x804b475 in Ensure1Window (cmdLineArgs=0x8128690) at nsAppRunner.cpp:470
#15 0x804ba34 in main1 (argc=2, argv=0xbffffa34) at nsAppRunner.cpp:570
#16 0x804bdf9 in main (argc=2, argv=0xbffffa34) at nsAppRunner.cpp:670
#17 0x402a1cb3 in ?? () from /lib/libc.so.6


second crash

#0  0x410e90b1 in nsScriptSecurityManager::GetSystemPrincipal (this=0x8247998,
result=0xbfffec74) at nsScriptSecurityManager.cpp:480
#1  0x40a1f1b5 in nsChromeProtocolHandler::NewChannel (this=0x81c4638,
verb=0x8051c5b "load", uri=0x819a708, aGroup=0x81a57a0,
eventSinkGetter=0x811ec68, originalURI=0x0, result=0xbfffecd8) at
nsChromeProtocolHandler.cpp:166
#2  0x4058c771 in nsIOService::NewChannelFromURI (this=0x812a378, verb=0x8051c5b
"load", aURI=0x819a708, aGroup=0x81a57a0, eventSinkGetter=0x811ec68,
originalURI=0x0, result=0xbfffed40) at nsIOService.cpp:233
#3  0x804d537 in NS_OpenURI (result=0xbfffee2c, uri=0x819a708, aGroup=0x81a57a0,
eventSinkGetter=0x811ec68) at nsNeckoUtil.cpp:69
#4  0x40a5dcbc in nsDocumentBindInfo::Bind (this=0x82a4930, aURL=0x819a708,
aLoadGroup=0x81a57a0, postDataStream=0x0, aReferrer=0x0) at nsDocLoader.cpp:1078
#5  0x40a5c618 in nsDocLoaderImpl::LoadDocument (this=0x8296d58, aUri=0x819a708,
aCommand=0x40a75614 "view", aContainer=0x824fd90, aPostDataStream=0x0,
aExtraInfo=0x0, aType=0, aLocalIP=0, aReferrer=0x0) at nsDocLoader.cpp:513
#6  0x40a65342 in nsWebShell::DoLoadURL (this=0x824fd90, aUri=0x819a708,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aType=0, aLocalIP=0,
aReferrer=0x0) at nsWebShell.cpp:2204
#7  0x40a65811 in nsWebShell::LoadURI (this=0x824fd90, aUri=0x819a708,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aModifyHistory=1, aType=0,
aLocalIP=0, aHistoryState=0x0, aReferrer=0x0) at nsWebShell.cpp:2280
#8  0x40a665cd in nsWebShell::LoadURL (this=0x824fd90, aURLSpec=0xbffff674,
aCommand=0x40a75614 "view", aPostDataStream=0x0, aModifyHistory=1, aType=0,
aLocalIP=0, aHistoryState=0x0, aReferrer=0x0) at nsWebShell.cpp:2472
#9  0x40a645c3 in nsWebShell::LoadURL (this=0x824fd90, aURLSpec=0xbffff674,
aPostDataStream=0x0, aModifyHistory=1, aType=0, aLocalIP=0, aHistoryState=0x0,
aReferrer=0x0) at nsWebShell.cpp:2031
#10 0x403feeea in nsWebShellWindow::Initialize (this=0x8296de8, aParent=0x0,
aShell=0x813c2a8, aUrl=0x82b03e0, aCreatedVisible=1, aLoadDefaultPage=1,
aCallbacks=0x0, aInitialWidth=1, aInitialHeight=1, widgetInitData=@0xbffff75c)
at nsWebShellWindow.cpp:440
#11 0x403fcf77 in nsAppShellService::JustCreateTopWindow (this=0x8128640,
aParent=0x0, aUrl=0x82b03e0, aShowWindow=1, aLoadDefaultPage=1,
aChromeMask=4094, aCallbacks=0x0, aInitialWidth=1, aInitialHeight=1,
aResult=0xbffff81c) at nsAppShellService.cpp:648
#12 0x403fce02 in nsAppShellService::CreateTopLevelWindow (this=0x8128640,
aParent=0x0, aUrl=0x82b03e0, aShowWindow=1, aLoadDefaultPage=1,
aChromeMask=4094, aCallbacks=0x0, aInitialWidth=-1, aInitialHeight=-1,
aResult=0xbffff81c) at nsAppShellService.cpp:583
#13 0x804ab7e in OpenChromURL (urlstr=0x8050aae "chrome://navigator/content/",
height=-1, width=-1) at nsAppRunner.cpp:292
#14 0x804b475 in Ensure1Window (cmdLineArgs=0x8128690) at nsAppRunner.cpp:470
#15 0x804ba34 in main1 (argc=2, argv=0xbffffa34) at nsAppRunner.cpp:570
#16 0x804bdf9 in main (argc=2, argv=0xbffffa34) at nsAppRunner.cpp:670
#17 0x402a1cb3 in ?? () from /lib/libc.so.6

I'm attempting to debug it now.

my tree is very fresh, 5pm nov 11.
Severity: normal → blocker
marking a blocker.
note, I only see this when I have exactly one 4.x profile, and the automatic
migrate occurs.

running installer with more than one 4.x profile doesn't crash.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
I can't reproduce this from home. I'll try it at work tomorrow.
I'm seeing this on windows, too.

on windows, remove your mozregistry.dat, and your Users50, and make sure you
have exactly one 4.x profile.

mozilla.exe -installer will crash
here's the stack crawl from windows:

02269d1f()
nsChromeProtocolHandler::NewChannel(nsChromeProtocolHandler * const 0x021d0800,
const char * 0x00371d64, nsIURI * 0x023446e0, nsILoadGroup * 0x02345050,
nsIEventSinkGetter * 0x02344030, nsIURI * 0x00000000, nsIChannel * * 0x0012f0b4)
line 166 + 47 bytes
nsIOService::NewChannelFromURI(nsIOService * const 0x0203d730, const char *
0x00371d64, nsIURI * 0x023446e0, nsILoadGroup * 0x02345050, nsIEventSinkGetter *
0x02344030, nsIURI * 0x00000000, nsIChannel * * 0x0012f10c) line 233 + 47 bytes
NS_OpenURI(nsIChannel * * 0x0012f1d4, nsIURI * 0x023446e0, nsILoadGroup *
0x02345050, nsIEventSinkGetter * 0x02344030) line 69 + 46 bytes
nsDocumentBindInfo::Bind(nsIURI * 0x023446e0, nsILoadGroup * 0x02345050,
nsIInputStream * 0x00000000, const unsigned short * 0x00000000) line 1078 + 49
bytes
nsDocLoaderImpl::LoadDocument(nsDocLoaderImpl * const 0x02345470, nsIURI *
0x023446e0, const char * 0x00370de4, nsIContentViewerContainer * 0x02344c50,
nsIInputStream * 0x00000000, nsISupports * 0x00000000, unsigned int 0, const
unsigned int 0, const unsigned short * 0x00000000) line 513 + 32 bytes
nsWebShell::DoLoadURL(nsIURI * 0x023446e0, const char * 0x00370de4,
nsIInputStream * 0x00000000, unsigned int 0, const unsigned int 0, const
unsigned short * 0x00000000) line 2204 + 57 bytes
nsWebShell::LoadURI(nsWebShell * const 0x02344c50, nsIURI * 0x023446e0, const
char * 0x00370de4, nsIInputStream * 0x00000000, int 1, unsigned int 0, const
unsigned int 0, nsISupports * 0x00000000, const unsigned short * 0x00000000)
line 2280 + 32 bytes
nsWebShell::LoadURL(nsWebShell * const 0x02344c50, const unsigned short *
0x0012fcac, const char * 0x00370de4, nsIInputStream * 0x00000000, int 1,
unsigned int 0, const unsigned int 0, nsISupports * 0x00000000, const unsigned
short * 0x00000000) line 2472 + 52 bytes
nsWebShell::LoadURL(nsWebShell * const 0x02344c50, const unsigned short *
0x0012fcac, nsIInputStream * 0x00000000, int 1, unsigned int 0, const unsigned
int 0, nsISupports * 0x00000000, const unsigned short * 0x00000000) line 2032
nsWebShellWindow::Initialize(nsIWebShellWindow * 0x00000000, nsIAppShell *
0x021cf6d0, nsIURI * 0x02345570, int 1, int 1, nsIXULWindowCallbacks *
0x00000000, int 1, int 1, nsWidgetInitData & {...}) line 441
nsAppShellService::JustCreateTopWindow(nsAppShellService * const 0x01fe8050,
nsIWebShellWindow * 0x00000000, nsIURI * 0x02345570, int 1, int 1, unsigned int
4094, nsIXULWindowCallbacks * 0x00000000, int 1, int 1, nsIWebShellWindow * *
0x0012fe10) line 648 + 47 bytes
nsAppShellService::CreateTopLevelWindow(nsAppShellService * const 0x01fe8050,
nsIWebShellWindow * 0x00000000, nsIURI * 0x02345570, int 1, int 1, unsigned int
4094, nsIXULWindowCallbacks * 0x00000000, int -1, int -1, nsIWebShellWindow * *
0x0012fe10) line 583 + 48 bytes
OpenChromURL(char * 0x004099a0, int -1, int -1) line 292 + 72 bytes
Ensure1Window(nsICmdLineService * 0x01fe8340) line 470 + 18 bytes
main1(int 2, char * * 0x00bf47f0) line 570 + 14 bytes
main(int 2, char * * 0x00bf47f0) line 670 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()
(Assignee)

Comment 6

19 years ago
This patch fixes the problem:

Index: caps/src/nsSystemPrincipal.cpp
===================================================================
RCS file: /m/pub/mozilla/caps/src/nsSystemPrincipal.cpp,v
retrieving revision 1.4
diff -r1.4 nsSystemPrincipal.cpp
33c33,37
< NS_IMPL_ISUPPORTS(nsSystemPrincipal, NS_GET_IID(nsIPrincipal));
---
> NS_IMPL_QUERY_INTERFACE1(nsSystemPrincipal, nsIPrincipal)
>
> NSBASEPRINCIPALS_ADDREF(nsSystemPrincipal);
> NSBASEPRINCIPALS_RELEASE(nsSystemPrincipal);
>
testing the patch now....
nice work, norris!

check that puppy in.  we'll need to respin.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Fixed:

Checking in nsSystemPrincipal.cpp;
/m/pub/mozilla/caps/src/nsSystemPrincipal.cpp,v  <--  nsSystemPrincipal.cpp
new revision: 1.5; previous revision: 1.4
done
leaf, can you respin for this?

Comment 11

19 years ago
is this just linux, or xp?
(Assignee)

Comment 12

19 years ago
It's xp.
(Assignee)

Updated

19 years ago
Hardware: PC → All
*** Bug 18678 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
builds 1999111608 for Linux/Win not crashing with one 4.x profile and the
mozilla -installer command

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 15

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.