Sidebar bottom scrollers incorrectly respond to middle and right mouse clicks under Windows

VERIFIED DUPLICATE of bug 180078

Status

--
trivial
VERIFIED DUPLICATE of bug 180078
16 years ago
14 years ago

People

(Reporter: jrofkar, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

The up/down sidebar scrollers near the bottom of the sidebar window either:

A) Incorrectly respond to middle and right mouse clicks.
...or...
B) Are painted incorrectly when the middle and right mouse buttons are clicked
on them.

Under Windows, I (and Microsoft ;-) prefer option (A).  In other words, neither
scroller button (up or down) should respond with a tab scroll when clicked upon
by the middle or right mouse buttons.

If such functionality were permitted with Windows GUI standards, then option (B)
would apply.  In other words, the scroller buttons do not depress (read: get
painted properly) when they are clicked with either the middle or right mouse
buttons -- yet they still perform their scrolling functions.

Reproducible: Always

Steps to Reproduce:
1. Press [F9] to toggle the Sidebar window ON.
2. With more than a half dozen tabs active, you should see the sidebar scroller
buttons visible near the bottom of the sidebar window.  If so, then continue. 
Otherwise, enable or add more sidebar panels until the scroller buttons are visible.
3. Right-click on either or both scroller buttons (up and/or down).

NOTE: You should have witnessed a scrolling action.  This is incorrect under
Windows.  Likewise, the buttons were never "depressed" to visually indicate that
they were being pressed.

4. Next, if you have middle mouse button (or a mouse scroll wheel that supports
clicking), click it.

NOTE: Again, you should have witnessed a scrolling action.  Like above, this is
incorrect.
Actual Results:  
Scrolling occurred, and it shouldn't have.  Also, the buttons were never painted
in a "depressed" state to visually indicate that they were being pressed.

Expected Results:  
If no pop-up, context-sensitive menu was assigned to these scrollers, then
Mozilla should have ignored both the middle and right mouse clicks.  Otherwise,
it should have displayed the pop-up menu.

I am using the Gray Modern theme, with both mouse gestures and autoscrolling
projects installed.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 180078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.