value of 'system colors' don't change on change of environment

RESOLVED DUPLICATE of bug 17978

Status

()

RESOLVED DUPLICATE of bug 17978
16 years ago
16 years ago

People

(Reporter: keizie, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

As http://www.w3.org/TR/REC-CSS2/ui.html#system-colors describe,
some value of colors have special fit to system-global environment.
and I like that idea to have in my personal pages.

Linux version of Mozilla support gtk-native theme with default mozilla theme.
but Mozilla does not apply new color to pages on change of system color.
and consistency break when I choose a new theme of gtk.
next time I start newly mozilla it's applied.

Reproducible: Always

Steps to Reproduce:
1. open a page has system color properties on mozilla.
2. change your theme to make system color properties changed.
3. take a look at page on mozilla.

Actual Results:  
mozilla itself change colors of widgets.
but pages remains last.

Expected Results:  
pages' color properties change to newly set ones.
Not a DOM Style bug, over to Style System (or Layout?).
Assignee: jst → dbaron
Component: DOM Style → Style System
(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 17978 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.