All users were logged out of Bugzilla on October 13th, 2018

Does not interpret javascript (correctly)

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: schellong, Assigned: asa)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.1) Gecko/20020925
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.1) Gecko/20020925

On the left side(frame) must be a link tree structure, but there is nothing
visible.
The file gsdc.htm from a Fujitsu-CDROM shows javascript source directly instead
execute it.
This does not work with Netscape [67].x too.

Reproducible: Always

Steps to Reproduce:
1. click
2. click again
3. click once more

Actual Results:  
No visible result or source text output.

Expected Results:  
A correct visible result.

See also:
http://bugzilla.mozilla.org/show_bug.cgi?id=185534

There are (intuitive) coherences.

Comment 1

16 years ago
Not a JavaScript Engine issue. JavaScript Engine deals with the abstract 
JavaScript programming language. Specifically, the low-level objects
such as String(), Number(), Date(), and RegExp(). The JS Engine does not
contain browser or DOM objects like window, document, trees, etc.

Reassigning to Browser-General until we can get more information.
The site WORKSFORME using Mozilla trunk binary 2002121908 on WinNT.
The tree in the left frame expands properly, and any link I click
opens the proper content in the right-hand frame.

Helmut:

1. I notice your build is from September. Could you try an
   up-to-date build and see if that fixes the problem? If so,
   you can resolve this bug as WORKSFORME.

If not,

2. Are there any errors in Tools > Web Development > JavaScript Console?
   (be sure to clear it of any previous errors first)

3. What setting do you have in View > Character Coding?
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → asa

Comment 2

16 years ago
WFM, day old trunk CVS, Linux.
(Reporter)

Comment 3

16 years ago
See:
http://www.schellong.com/moz.jpg
http://www.schellong.com/mozcd.jpg
http://www.schellong.com/konqcd.jpg

3.) ISO-8859-1
2.) mozcd.jpg only:
    ---------------
    Error: unterminated string literal
    Source File: file:///cdrom/FuMCSite/gsdc.htm
    Line: 928, Column: 12
    Source Code:
    writeln("
Mark: Mozilla and Konqueror: FreeBSD
      Netscape v6 and v7 does not work in the same way --> W2K!
1.) The most new package for FreeBSD is v1.2b ...

Comment 4

16 years ago
OS -> FreeBSD until it's reproduced on another OS.
Is the URL still valid, as I get a 500 server error.
OS: All → FreeBSD

Comment 5

16 years ago
No problem on 2003-02-14-09 CVS build on FreeBSD 4.7.
This should be WFM.

Comment 6

16 years ago
Reporter: Are you still having this problem with a recent build?

Comment 7

16 years ago
WFM (Mozilla 1.3.1 on FreeBSD 5.1). Marking WFM as well as changing test URL
from http://www.fme.gsdc.de/gsdc.htm?macrofam/tools.htm to
http://www.fme.gsdc.de/gsdc.htm , since the old test URL seems to be broken by
now. If somebody can still reproduce this bug with a recent build, then feel
free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.