Doesn't remember MIME settings

RESOLVED INVALID

Status

Core Graveyard
File Handling
--
major
RESOLVED INVALID
16 years ago
2 years ago

People

(Reporter: Ken Brawn, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

When I click on a link to a file (e.g. a .jpg image) within a web page, a popup
asks me which app to use, even though it is already defined in Windows.  I
assign one.  The next time I select a link of the same type, it asks me again. 
Every time.  It did this in Version 1.2.1 as well, but not before that.

Reproducible: Always

Steps to Reproduce:
1. Go to web page containing a link to a jpg file
2. Click the link
3. Tell popup which app to use
4. Go back to the page and click it again
5. Popup will ask again

Actual Results:  
See above

Expected Results:  
Remembered which app I told it to use for that file type, or got the info from
Windows

Comment 1

16 years ago
->File Handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen
Could you go to:
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
and download a new build, and retest?
This should be fixed now.
(Reporter)

Comment 3

16 years ago
Tried the 1/13/03 nightly build as suggested, but...

Now when I select a jpg link it pops up a box with the additional option "Open
it with the default application". But when I select this and uncheck the "Always
show this dialog...", it opens the image correctly, but the next time it pops up
the same dialog.  I just want it to go to the default tool (in my case, Mozilla)
to open a jpg file without it asking me every time.
OS: Windows 98 → Windows 2000
Sounds like the site is setting an explicit header that says the jpeg is _not_
to be handled inline.. What site is this?
Ken: Does this bug only happen on a specific url?
(Reporter)

Comment 6

15 years ago
The problem seems to be localized to mail.com.  Apparently the problem is
theirs, although Netscape 4.7 handles the files correctly.  Don't know where to
go from here.
Netscape 4 has no support for "content-disposition: attachment".  We do.

Could you possibly try a recent build and see whether the message on the dialog
is that we can't handle the type or that the site asked us to not handle it?
(Reporter)

Comment 8

15 years ago
I installed the nightly build (1.5b), and when selecting .jpg file from mail.com
the popup says "The site has suggested that <filename> be handled as an
attachment.  It is of type image/jpeg (JPEG Image) and located at
http://mail01.mail.com/getattach/".

It then asks what to do with the file, and the first option is to Open it with
the default application.  This is a nice new option that helps a lot.  However
the checkbox to "Always show this dialog before handling files of this type" is
checked and grayed out.  I'd like to uncheck this so that it works by default.
> However the checkbox to "Always show this dialog before handling files of this
> type" is checked and grayed out.

That's correct.  Sites using that option expect the user to just be given a
filepicker to save the file (that's what IE does).  We give the user a choice to
use a helper instead, but we can't just automatically start the helper because
that breaks some use cases.... this will especially be the case when one of the
options on that dialog is "view in browser anyway".

Sounds like things are working exactly as they are supposed to....
INVALID per last comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.